Media files refuse to respond properly to OpenLP 2.4.6

eded
edited September 14 in Troubleshooting

I am using OpenLP Ver 2.4.6 on Windows 10, Version 21H2 (OS Build 19044.1889) fully up to date.

HP Pavilion 15 Notebook.

Processor: Intel(R) Core(TM) i5-4200U CPU @ 1.60GHz  2.30 GHz

Installed RAM: 8Gb

System Type: 64-bit OS

VLC 3.0.16 installed. It will play all the usual file types and is set as the Windows default.

PROBLEMS:

OpenLP will happily play .mp3 files linked to words. i.e Select a song > Edit > select "Linked Audio" tab and add the relevant data. Add to a service and it happily plays.

HOWEVER, in the left hand section under "Media" selecting a media file of whatever type (mp4, avi, even an mp3) and OpenLP will not allow me to add it to a service, nor will it preview or play in any way at all. After several seconds an error pops up saying "Unsupported file type" and that's it!

In OpenLP > Settings > Configure OpenLP > Players I have the following selected in this order:

1. VLC

2. WebKit

3. System.

No other options are available to me. I have tried only selecting VLC - no difference!

Under Settings > Configure OpenLP > Media neither of the following are ticked:

"Allow media player to be overridden"

"Start Live items automatically"

They are all unticked. 

Similarly I can add a LibreOffice Presentation to the service, but when I come to run it - nothing. It sits there. Clicking through the slides achieves no result on the screen. I am using version 7.3.5.2

Individual .JPG and .PNG files display and respond properly.  As do song words with music as indicated above.

It is also extremely easy to loose focus on OLP and it requires a careful double clicking on the relevant service item to restore focus. (I use a simple Taurus clicker)

I have reinstalled OLP, checked mouse settings, and gone through the things above, and cannot see why I have a problem. 

I own up - I did do a bit of a cleanup removing MS apps I never use, including Movie and TV. However I have reinstalled this, and it makes no difference. Have I inadvertently removed some vital system file? A widows 'Restore' is not an option as I would restore a load of junk I do not want as well!

OpenLP worked fine before Covid, but this is its first venture out. Any ideas please as to how to sort this? Or perhaps my OpenLP has Covid!

Thanks

Comments

Sign In or Register to comment.