OpenLP 3.0 doesn't open on MacOS (Powerpoint not installed?)

edited January 16 in General Support

I've just upgraded from 2.4.6 on my Mac (running MacOS 11.7.1).

After the upgrade, OpenLP won't open—unless I run it in debug mode. I wonder if this has something to do with MS Powerpoint not being installed on this computer?

When I open the application, the icon appears in the middle of the screen, then a dialog opens asking for where Powerpoint is located. After clicking Cancel nothing else happens and I have to Force Quit.

In openlp.log I see this:

2023-01-02 10:21:57,829 MainThread openlp.plugins.presentations.lib.powerpointmaccontroller ERROR Compilation of Powerpoint applescript failed
Traceback (most recent call last):
  File "openlp/plugins/presentations/lib/powerpointmaccontroller.py", line 287, in __init__
  File "applescript/__init__.py", line 49, in __init__
applescript.ScriptError: Expected end of line, etc. but found identifier. (-2741) range=1675-1687

A strange thing is, when I run openlp from the command line with the `-l debug` switch, the application starts as expected. In the setting panel, the settings for Powerpoint are ticked but greyed out (so I can't 'untick' them).

Any ideas?

Comments

Sign In or Register to comment.