VLC output to amplifier

edited February 10 in General Support

Win 10 (64) OpenLP ver 3.0.2

Very, very new to this. Need to play my songs directly from VLC to our amplifier. The audio from songs has been removed . Hoping to see the text projected which it does fine. When I run VLC connected directly to the amplifier I get no sound. Of course if I have the media included as part of the song profile the same occurs. Is it possible for me to get the sound playing through the amplifier sound system?

Hoping for a positive response. BTW, love this software as does my congregation.


  • In Settings, on the Media tab, you can provide additional arguments for VLC that should be able to redirect the audio to specific outputs. You'll might need to read the documentation of VLC to find the correct arguments.

  • tgc

    Many thanks for your reply. You are correct though it took a lot of reading and many attempts. For anyone else here's what I did to get the audio to play to the amplifier.

    My environment:-

    I'm using the latest OpenLP with the Web interface, Win10 (64), and latest VLC


    1. In OpenLP.
    2. Go to Configure OpenLP
    3. Select "Media" from the left panel
    4. in "Extra arguments enter "--no-audio" (exactly as shown here but without the quotes)
    5. Click OK to exit Configure OpenLP
    6. Exit OpenLP
    7. Open VLC on your computer and keep it open
    8. Select "Audio" from the headings
    9. For "Audio Device" select "Speaker/Headphone" In my case this is the audio output from the computer to the amplifier
    10. In VLC add the audio you wish to play in the order you want to plat them (you can save this list by right click and save)
    11. Restart OpenLP
    12. Select the song to play in OpenLP
    13. Play the song directly from VLC

    Hope this helps at least one person as these things can be very frustrating especially to newbies to OpenLP like myself.

  • edited February 11


    "Seek and ye shall find"

    What excitement. I have found a simpler way.

    In OpenLP-Settings-Configure OpenLP-Media(from left box)-Extra arguments

    enter this text:-

    Audio--sout-es-access-audio="Realtek HD Audio"

    Replace "Realtek HD Audio" with your output device

    Praise the Lord and thanks again to tgc for the inspiration to research this.

Sign In or Register to comment.