OpenLP 3.0.2 has been released!

edited February 10 in General Support

OpenLP 3.0.2 is out! Update for all the latest fixes and goodies!

Get the details here:


  • Hey yall, still having an issue creating video themes. It seems as if the "background color" overrides the actual video, leading to the video not being shown at all, just the background color. Has anyone else encountered this issue?

    Running vs 3.0.2 on Windows 10 64 Bit.

  • I am having the same issue.

    To resolve the issue I have to disable and re-enable X11 bypass and disable then re-enable Disable transparency. Sometimes I have to do this multiple times to get the video background loop to work.

    I am using an AMD Ryzen5 with integrated graphics on Windows 10 64bit. I have not run into this issue on Intel based CPUs.

  • The X11 bypass does nothing on Windows (it is only for Linux). We're looking into the video background issue.

  • edited March 8

    Having an issue with multiple instances of PowerPoint opening every time I push a button on the service in Windows 11. I had up to 14 instances at once with only one presentation. If I try to select a specific slide a new instance starts. If I move from the presentation to another service item and back, a new instance opens. Eventually OpenLP stops responding and I have to close everything down.

    Edit: I found a workaround for this issue. Our PowerPoint is a series of animated slides with weekly announcements set to a continuous loop. There are two options I've found: 1. Save the presentation as .jpg and import slide images to an image group. You can then set OpenLP to loop the group. The problem is I lose all my animation and transitions and I have to set the loop from the computer so no remote operation. 2. The better option in my opinion is to export my presentation as an animated .gif so I keep all my animations and transitions and it will automatically loop so it can still be controlled remotely.

    Edit, again: So it turns out the animated gif causes the file to be too large and OpenLP reads it as a corrupt file. I was able to export as an MP4 and so far haven't had any troubles. You can still loop the playback so I'll go with this less than ideal workaround until the bugs get fixed.

    Edit 3: MP4 only shows black screen. Gone back to 2.4.6 until some more bugs can be worked out.

  • Has anyone been able to install 3.0 on linux mint? The version on the Software Center is 2.4 and when I try to add the OpenLP PPA to enable me get 3.0, I get the message "This PPA does not support focal". Any help please?

  • edited February 27

    On macOS Ventura, M1 chip, OpenLP throws an error whenever I click the File menu. Looks like it's a "file name too long" error due to a couple of files in the "recent items" list. Apparently Google Drive's new stupid-long paths are too much for it.

    Workaround was to open ~/Library/Preferences/org.openlp.OpenLP.plist using a plist editor, find the "core.recent files" entry, and remove the entries with long paths.

    On the VLC issue...if I have the arm64 version of VLC installed, OpenLP runs fine, but says VLC is missing. If I install the intel64 version, OpenLP hangs on start and I have to force-quit. If I install the universal binary version (, OpenLP also hangs on start and I have to force-quit. Tried installing VLC using MacPorts, OpenLP has no idea it's there.

  • Tried installing VLC using MacPorts, OpenLP has no idea it's there.

    Do you mean that OpenLP behaves in the same way as when you have the Arm64 version of VLC installed? That is, do you get the same message, 'VLC is missing'?

  • I noticed two things that I find concerning.

    1. OpenLP 3.0.2 takes almost twice as long to start as the version we were using (2.4.x)
    2. the icon pack is ugly and doesn't look like the task that it's supposed to do. e.g. the icon for blank to theme doesn't look anything like blanking to theme, and the blank to desktop has an X through it. Why? it doesn't make any sense, and seems like a massive step backwards in usability. How am I supposed to explain what it means to the less tech knowledgeable users? Who thought this was better?
  • I'm getting an error when downloading 3.0.2. It says “OpenLP” is damaged and can’t be opened. You should eject the disk image.

    Therefore it's not opening or taking me to the installation.

    Please help!

  • I can only presume that you're running on a Mac.

    From the Blog



    macOS reports OpenLP as damaged, due to the OpenLP app not being signed. If you encounter this problem, you can try the following solution:

    1. From Applications / Utilities run Terminal
    2. In Terminal, type in the following command:
    xattr -dr /Applications/
    1. In some cases, you may need to append sudo to the above command
    2. This should allow you to start OpenLP normally

    However, as you're running on a Mac, I have a cautionary tale for you. The following entry on the blog deals with Macs running Apple's 'new' chips, as opposed to the Intel chips that Macs have run for the past 20(?) years.

    VLC will almost certainly not run in conjunction with OpenLP.

    You can try any number of different ways to get VLC to come out of hiding, but openLP refuses to find it. ????

  • I use mint. I just download the source code, open the folder and double-click on the "" file, then select "run". It works fine (mostly).

  • Still some problems with the web remote that need to be addressed:

    1. It is not possible to adjust the font size in the stage view or chords view (this is a big drawback and makes it unusable).
    2. In the 2.4 version, at the end of a song item, in stage view, it displayed "Next Item" at the bottom. I found that very helpful. It's totally missing this feature in 3.0 please bring it back.
    3. In the 2.4. version, whatever I put between [square brackets] did not display on the main view, but did display in the stage view or chords view. Now I can't use that feature because it fags it as being not a recognised chord. Even if it's not a recognised chord, just leave it alone.
    4. Being able to edit the song and change the key is a great feature, however, every time I press the "up" or "down" button to change the key, it immediately takes me to the bottom of the song, where I can't see the [=G] key signature, and then I have to scroll all the way up again. It's most frustrating.
    5. Lastly, when editing a song on my laptop, the font in the edit box is so tiny I can't see it well enough. It would help if I could change the size of that font.
    6. In version 2.4 I was able to go to "print view" in the remote, which was black on white and print the whole song with the chords and correct verse order. I would love to have that feature back.
    1. Did you try the Settings in the burger menu? With that, I can adjust the font size for each stage view and chords view

    6. When you print a service (Ctrl+P) you can choose to print also the chords. Sounds to me like the feature you are missing.

Sign In or Register to comment.