Cannot load service file.

Here is the issue.

I prepare the service and save it it.

Then when I try to open again it cannot.

Roughly the message says the service file ... .osz could not be loaded because it is either corrupt, inaccessible or not a valid OpenLP 2 or OpenLP 3 service file.

I created the service on OpenLP 3 so it cannot be the wrong file.

I thought that the issue might be because I saved it a network place (Google Drive) but then I saved to the local computer, and it happened again.

Any idea? Solution? Anyone having the same issue?




  • Yes! I am suddenly getting the same issue - Windows 10, OpenLP 3.02. Was this issue ever resolved?

  • I would need a log file from you to be able to do anything (see the manual for more details).

    Also, what does your service file contain?

  • edited March 18

    Is this the message? I'm running on macOS, so it will look a bit different.

    I thought that I was told that a fix was available but it hadn't yet been published.

    If that's the case, I'd like it very soon, like yesterday, please. I am getting frustrated preparing a service, saving it (all of which I do at home) and then going to the church only to discover that I have to recreate everything because I can't open what I had previously saved.

    Or, if you know a way around that problem …

    And, like @Conrad , I initially wondered if the problem was caused by me saving the file to a cloud drive. And to rule out any particular cloud provider, I signed up for 5, maybe 6 providers' free accounts! And then I finally went to the local drive where it still didn't work.

  • This is probably because the file is over 2GB in size. Please save the service as a "lite" service (it's there in the file type options in the save dialog, been there for years). This excludes external files from bloating the service file.

  • Fair enough, Raoul.

    But that prevents me preparing a service on one computer (at home), and then using a different computer at church, doesn't it?

  • Yes, in that particular case, it does. We've thought about making the path to the media file relative to the service file when you save the service, and that way you could just put the media file next to the service file, and it'll work wherever it is. Having said that, I'm not sure if OpenLP actually does that yet.

  • I have a similar but slightly different problem and I'd love some help.

    I have two computers running OpenLP: a Windows 10 running 2.4.6 and a Windows 11 running 3.0.2.

    My playlists, which I made on 2.4.6, are saved on OneDrive. Back when both computers ran 2.4.6 (which was until 3.0.1 was released), there was never an issue opening and updating the playlists on either computer.

    Since updating one computer to 3.0.2, I hadn't experienced any issues with opening and editing the same playlist in 2.4.6 and 3.0.2. However, today I tried opening one of my playlists (which is only 21 KB in size) on 2.4.6 and it gives me an error message and didn't load any items in the service. However, when I open this service file on 3.0.2 it works fine.

    Here's a screenshot of the error message I get when I try opening the playlist in 2.4.6 (there's oddly no option to save the error log, which is unusual):

    I've tried opening my other playlists in 2.4.6 (I've also been using these playlists in 3.0.2) and they're opening with all the service items included. All these playlists only contain song files, a few custom slides and a few images - no video or audio.

    Also, on 3.0.2, I've tried doing "Save As" to the service file that doesn't open on 2.4.6. This new copy opened fine on 3.0.2 but didn't work on 2.4.6.

    Any idea on how to get this service file opening on 2.4.6? Thanks!

Sign In or Register to comment.