Problem with Windows Installer Package & old version deleted?

I was running an older version of OpenLP and unfortunately tried to 'update' with the most recent version. Now when I try to open ANY of my old services to create a new one (out of hundreds of songs, photos, backgrounds etc. which I created over the last years) all I get is the 'OPENLP' icon and NOTHING happens.

I thought I might have to bite the bullet and download the new version and re-enter ALL my files (ugh), but it will not let me install after the download. First note I get is " File C:\Program Files (x86\OpenLP\unins000.dat' does not exist. Cannot uninstall " The the next window tells me: " There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. " I downloaded 3 separate times and tried to install and get the exact same error message every time!

Please help - how could I recover my 'old' OpenLP ??



    Sorry to hear about your troubles. Which version did you upgrade from? And just to be sure, which version are you trying to install?

    You mention that you can't open older service files, but don't you have the songs etc available from inside openlp?

    Regarding downloading older versions of openlp, you should go here:

    For a guide for downgrading, look here:

    I've never seen the install issues you're mentioning, so unfortunately I can't help you there ????

Sign In or Register to comment.