Resolution of Application Window gets messed up...

I was using OpenLP without any problem on my laptop some months ago. Tried opening it recently, and this is how the application window looks like when I open it...

The preview display, as you can see works fine... And if I connect it to an external display, the final projection works fine too.

But, because of this issue with the application window, I'm not able to use it.

The application actually works and it seems to be working in the correct resolution... If I move my mouse by guessing where the various buttons are, I'm able to click on certain things. For example, I can open the Config Window from the menu, and it opens fine...

I've tried various ways of resolving it, but no luck. I've tried changing the compatibility mode and opening the application. I've tried opening it with and without connecting it to an external display. I've tried updating my graphics drivers as well.

All the other applications on my system work fine.


I did notice that for a split second after opening, the correct resolution is displayed.

I managed to grab a screenshot during that split second and it does look fine. But, it immediately defaults to the messed up resolution and stays that way.

Any suggestions on how to fix this?

Thank you so much.


  • Sorry.. I just figured out a fix. Not able to delete this post, so I'm just sharing what I did, so it might be of use to someone else with this issue.

    I'm using a laptop with an nVidia graphics card.

    I opened up Windows Display Settings. Then, under Related Settings, Graphics... Added the OpenLP app by clicking on Browse, clicked Options under the newly added OpenLP option, and set it to use the nvidia graphics card instead of the Intel card.

    Opened OpenLP again, and it is working now!

Sign In or Register to comment.