Windows 11 Open LP won't start

Hi All.

I've just built a new media PC for my church and due to the writing now formally being on the wall for windows 10 decided to splash out on a Windows 11 license. Having checked these forums it looked as though OpenLP worked on Windows 11 for most people without problem.

However I simply can't get it to open. I've tried 3.0.2 and even reverted to back to 2.9.5 but no luck.

I've run the debug mode in 3.0.2 and get an incredibly short log file which, reading between the lines and having done a quick google appears to indicate a python debugger error more than an error with open LP.

Does anybody have any ideas what's going on?

The log is as follows: -

Windows fatal exception: access violation

Current thread 0x00000ad0 (most recent call first):

File "openlop\core\", line 417 in main

File "openlp\", line 75 in start

File "openlp\", line 79 in <module>

For the record I'm running:-

Ryzen 5 5500 (6 Core 3.5GHz), 16GB RAM, 256GB NVMe, Matrox M9148 Quad DP Graphics.


  • Hi again all.

    So, thought I'd best update. I have out of total desperation, and interest, I've just removed the graphics card and plugged in my old GTX970.

    Sadly, I didn't get the outcome I wanted in that Open LP spun up without a hitch. Yes I know this sounds odd. AndI'd driven the graphics card from my mind as, although it appears in the troubleshooting pages, i wasn't get an error message as mentioned.

    I'd chosen the Matrox for lots of reasons including the number of outputs that it's passively cooled (Fans are a big noise problem for us, as is rack heat in general) and most importantly it's half height, short length, and so low power it doesn't require a dedicated cable it'll power from the slot.

    The PC is, out of necessity in a 2U 300m deep chassis and I had to remove the power button and drive bays to get the 970 in. So the Matrox not working is a big problem for me.

    Anybody got any ideas why the Matrox isn't working? I'm running the latest drivers, which I'll admit are marked as Windows 10, but 11 is happy with them and office etc all run fine. I'm more than happy to help the dev team in any way I can, but I'm no Python, nor Windows programmer (Give me some C on Linux please).

Sign In or Register to comment.