CCLI Import stopped working in 1.2.4

edited 7:37AM in Development

After upgrading two moths ago to v. 1.2.4, the CCLI Import worked well. Then, all of a sudden it stopped importing Lyrics but DOES import Artist, Copyright, etc, just not the lyrics. Any suggestions? Nothing else has changed that I am aware of on this PC.

Many Thanks,


  • edited February 2010

    Sorry! I think this ended up in the wrong forum area.

  • edited March 2010

    I have heard that the SongSelect site has been having issues recently from some of our users who use SongSelect. This might be the cause.

    Our 1.2 developer is currently on a business trip, but he'll have a look at it when he gets back.

  • edited March 2010

    The reason is that CCLI used to provide text for people to copy on the Song detail page. Now they have switched to a picture because they want to track lyric downloads. This is why you can't copy and paste the lyrics anymore.

    So this is not an openlp problem, CCLI/SongSelect upgraded their site and software which screwed openlp.

    To fix this you'll have to go to the songselect site and download the .txt file of the song you want then go back to openlp and select import songselect file, then choose the .txt file you downloaded.

  • edited March 2010

    Jono is 100% correct.  CCLI changed the SongSelect to enable them to do (more) accurate download tracking since this is one of the criteria they use when paying royalties to the song authors.

    You should still be able to import the songs through the CCLI web interface in OpenLP though.  The way it now works (or at least did work, unless something has changed again) is that when you try and download the .txt or .usr file of the song, OpenLP catches the download request and does the file import automatically. If this is not working then I need to tweak the interface again.

    As Raoul mentioned above, I am currently on a business trip until almost the end of March so I won't be able to make any corrections until then, but please let me know if the procedure I described above doesn't work.

Sign In or Register to comment.