Help - can't seem to fall back to working version after issue with 1.2.4 upgrade - SQL Logic Error

edited 10:50AM in Troubleshooting

We tried to go from 1.2.2 to 1.2.4 to take advantage of some powerpoint fixes but had stability issues.  I tried to re-install 1.2.3 and it seemed to work but we're having issues with editing / saving OOS files.

We are running Win 7.

The behavior we are seeing now is as follow:

Changed compatibility on 1.2.3 setup file to xp sp3 and 'run as admin'.

Ran setup, which completed without error.  Rebooted.  D3DRM.DLLL existing in Windows directory.

Ran Open LP.  Added three songs A,B,C and image 1 to a new OOS.  Saved the oos and exited OpenLP.

Ran OpenLP.  Added song D.  Hit the save button and got the following error dialog:

            Error Saving Blue     SQL logic error or missing Database

I have tried to do complete un-installs of OpenLP and 'full installs', etc.  with revs from 1.2.2 to 1.2.4.

In all cases I either get 'Index out of bounds' errors or songs / images duplicated each time I save the OOS.

We are beginning to panic as the weekend is closing in and while we have the OOS's for this weekend almost finished, we can't seem to add the last few items that are required to finish things up!

Any help would be appreciated.  I'd especially like to know how to completely remove all parts of OpenLP so I could try a truly clean install.  there seems to be parts left in the registry and other places even after the 'uninstall' is executed.  Any chance this is related to a java update, windows update or security update? 

Thanks!

Scott

 

 

Comments

  • edited March 2010

    One other note.  When the save OOS function fails, it generates a 'oos journal' file.  When this occurs, the oos file is empty the next time you attempt to load it..

  • edited March 2010

    The OOS file is a SQLite 2 database. Unfortunately SQLite 2 is very old, and there are few utilities for it these days. If you can get hold of a SQLite 2 utility and then run a VACUUM on the file, it'll recover the OOS.

  • edited March 2010

    First of all, are you running as an admin user or standard user? If the latter, you may have more joy with an admin user.

    A workaround until the real issue can be solved is to try doing a File -> Save as, and giving the amended file a new name and seeing what happens.

    As for the cause:

    Are you saving the OOS files to your Documents folder, rather than somewhere outside the normal saved places? I'm wondering if it's a permissions issue. I see you are even having trouble with brand new OOS's, which seems a bit odd. Maybe anti-virus software? The software doesn't use Java and I don't think a Windows Update would affect things.

    Vista/Windows 7 also have a thing called compatibility files, which if a program doesn't have permission to change a file, it creates a copy that can be edited. To see if this is the case, browse to the folder where you are saving the OOS and see if there is a "Compatibility Files" button underneath the address bar in explorer. If so, then OpenLP may be getting confused as to which one to write to.

    The openlp registry settings are unlikely to affect the saving of files, as are anything in the data files, but if you really wanted to completely clear everything down (lose your song database, bibles, themes), do a normal uninstall first.

    Then go into regedit and delete the tree: HKEY_CURRENT_USER\Software\openlp.org

    Delete the data files are in C:\ProgramData\openlp.org
    Delete the program files in C:\Program Files\openlp.org

    Also check for compatibility files for these folders. If the button appears, click it and delete any files that may appear.

     

  • edited March 2010

    Thanks for the pointers.  I'll try them this morning.  I agree it seems to act like a permissions issue at this point.  That is one reason why I was anxious to try and delete everything (all files, directories, etc.) and try again. 

    I am running as an admin user. 

    Scott

  • edited March 2010

    I suspect I still have permission issues, but by disabling my Antivirus I can once again edit/save OOS files.  When I toggle the antivirus back on, the failure modes return.  This should get us through the week and I'll do some more work next week to try and isolate why the antivirus feels "threatened"!

    Thanks again for the pointers.

    Scott

  • edited March 2010

    Well glad you've got a workaround for the time being.

    Would you be willing to let us know which antivirus software you're using, just in case others hit (or want to avoid hitting!) the same problems?

  • edited March 2010

    I had a similar problem when installing version 1.2.4 to a Win7 laptop I kept getting error messages when I tried to save an Order of Service (oos)file.

    I prefer to save oos files to a subfolder in the documents folder. After the initial instal there was no problem until I created this subfolder, and tried to save an oos to it. I kept getting errors. I tried running in XP compatability mode, and running as an administrator, but to no avail, just got this error message.

    Pause for prayer Smile

    I had saved several trial oos files into the documents folder, the problem only occured after I copied these to the subfolder and then tried to modify them from within Openlp. I closed Openlp, copied an oos file from the sub folder into the documents folder and clicked on it.  This opened the program displaying the oos.  I then modified the oos and was able to save it without an error message.  I then closed the program and opened it again succesfully by clicking on a previously saved oos file within my new subfolder.  After this I found I could open the program via the desktop shortcut and save oos files in the subfolder without error.

    I suspect that Openlp had trouble finding the oos files until I taught it the new location, some glitch between OpenLP and Win7- I will leave that to the experts!

    Hope this helps someone - Prayer is the answer! Laughing

     

  • edited March 2010

    Sure.  We are using the latest version of Trend Micro's Internet Security Pro.

Sign In or Register to comment.