Fatal Error OpenLP Returned -1

edited September 18 in Troubleshooting
I shut my Open LP down after church this morning, and now that I am trying to restart it, it keeps giving me this error message.  "Open LP Returned -1.  HELP!!!!!!!!!  


  • This error seems to be a corrupted configuration. Did OpenLP shut down properly? Did you suspend your computer while OpenLP was running at all? Did you upgrade OpenLP recently?

    Backup your configuration by renaming it, and then re-run OpenLP. To find out where your configuration is stored, see this question in the Frequently Asked Questions section of our manual: https://manual.openlp.org/faq.html#where-do-i-find-the-configuration-file

  • edited November 2016
    Mine did the same thing last Sunday Sept 30th.  Didn't come along this until today.  I ended up having to install an older version (2.2.1 I think) to get it to run again. I tried changing back to v2.4.3 but no luck.  Stuck with the 2.2 version I had been using.  Will try v2.4.3 again and see if the config file is causing the issue.  But wonder why it would work with the old version?

    Was just looking at the link for where config file is.  For Windows it is in the registry.  You want us to rename the registry entry HKEY_CURRENT_USER\Software\OpenLP\OpenLP to something like HKEY_CURRENT_USER\Software\OpenLP\OpenLP_Backup ?
  • @bahenney : yes, if you rename the settings entry then a new OpenLP entry will be created by OpenLP when you start it the next time. Hopefully that will mean that the error will disappear.
  • I am getting this Fatal Error OpenLP Return -1 currently on the PC at church.   The PC is windows 10.  I have tried 
    Uninstalling and reinstalling... also with rebooting in-between.  
    Uninstalling Renaming the registry keys as pictured above, then reinstalling. 
    I also searched for the location of the configuration file in windows 10 I can't seem to find that location.    Is the location different in Windows 10?
    I have downloaded the portal version that is working so I might have to use that this Sunday.      
    Any other ideas?  
    Thank you for your time,
    Rob Allam
  • @RAllam On Windows 10 the settings are stored in the registry.  You can use Reg Editor to find and remove the registry item.
  • Hi, I am having this error as well after upgrading the church computer from Ubuntu 18.04.4 to 20.04.1:

    Traceback (most recent call last):

    File "/usr/bin/openlp", line 44, in <module>


    File "/usr/share/openlp/openlp/core/__init__.py", line 437, in main


    File "/usr/share/openlp/openlp/core/__init__.py", line 142, in run


    File "/usr/share/openlp/openlp/core/common/registry.py", line 137, in execute

    result = function(*args, **kwargs)

    File "/usr/share/openlp/openlp/core/lib/pluginmanager.py", line 60, in bootstrap_initialise


    File "/usr/share/openlp/openlp/core/lib/pluginmanager.py", line 122, in hook_media_manager


    File "/usr/share/openlp/openlp/core/lib/plugin.py", line 204, in create_media_manager_item

    self.media_item = self.media_item_class(self.main_window.media_dock_manager.media_dock, self)

    File "/usr/share/openlp/openlp/plugins/media/lib/mediaitem.py", line 58, in __init__

    super(MediaMediaItem, self).__init__(parent, plugin)

    File "/usr/share/openlp/openlp/core/lib/mediamanageritem.py", line 82, in __init__


    File "/usr/share/openlp/openlp/plugins/media/lib/mediaitem.py", line 90, in setup_item

    self.media_controller.setup_display(self.display_controller.preview_display, False)

    File "/usr/share/openlp/openlp/core/ui/media/mediacontroller.py", line 322, in setup_display


    File "/usr/share/openlp/openlp/core/ui/media/vlcplayer.py", line 157, in setup

    display.vlc_instance = vlc.Instance(command_line_options)

    File "/usr/share/openlp/openlp/core/ui/media/vendor/vlc.py", line 1411, in __new__

    return libvlc_new(len(args), args)

    File "/usr/share/openlp/openlp/core/ui/media/vendor/vlc.py", line 3629, in libvlc_new

    _Cfunction('libvlc_new', ((1,), (1,),), class_result(Instance),

    File "/usr/share/openlp/openlp/core/ui/media/vendor/vlc.py", line 246, in _Cfunction

    raise NameError('no function %r' % (name,))

    NameError: no function 'libvlc_new'

  • You need to install vlc and python3-vlc.

  • Hello DANBIM, what have you tried so far. The upper comments state in two possible directions. One was a missconfiguration and is stored in the registry files of windows and the other is the missing video player software "vlc".

    Was it an Update to Win 10 on your computer or what was the background while it's not working anymore?

    Greetings - Simon
  • Hello!

    I am working with a Windows 10 system, and have been using OpenLP with voracious regularity for at least 2 years. We have built up a substantial song library, and we use the program constantly.

    I recently opened the program to work up a service and received a fatal error message as described above. I was able to download VideoPsalm and the database imported almost seamlessly. We do not want to continue using this substantially different program, however, but have not been able to open the program--even the previous versions. Any help in this area would be wonderful.

    Thank You!

    A. R. H. (Jeruel Baptist)

  • The surest way to fix this is to reinstall OpenLP....your current database should be OK provided it isn't the cause!

    1. select the windows start button and type 'regeditor'
    2. open the regeditor and look for the Openlp folder.
    3. delete the OpenLP folder and close regeditor.
    4. Run the OpenLP installer, you can download it from the website if you no longer have it....just be sure it is the same version as you used previously.
    5. As the installer goes through the process you do NOT need to select any Bibles, songs or themes.
    6. When it finishes you should be able to run OpenLP again and your data should be ready to use. You may have to modify your settings to get everything acting the same as it did before it stopped working.
  • edited January 2021

    Thanks JohnM!

    I was able to reinstall it in a new folder in my "Program Files" and it worked great. I was also able to reimport my library perfectly. Thanks for your help! We are so glad to have our preferred program back up and running.

    God Bless!


  • Hello.

    OpenLP won't run on Linux Mint 19.3.

    Error while running in console:

    ~$ openlp

    Traceback (most recent call last):

      File "/usr/bin/openlp", line 27, in <module>

        from openlp.core.common import is_win, is_macosx

      File "/usr/share/openlp/openlp/__init__.py", line 26, in <module>

        from openlp import core, plugins

      File "/usr/share/openlp/openlp/core/__init__.py", line 43, in <module>

        from openlp.core.ui.mainwindow import MainWindow

      File "/usr/share/openlp/openlp/core/ui/mainwindow.py", line 29, in


        from distutils import dir_util

    ImportError: cannot import name 'dir_util'

    Error in sys.excepthook:

    Traceback (most recent call last):

      File "/usr/lib/python3/dist-packages/apport_python_hook.py", line

    154, in apport_excepthook

        os.O_WRONLY | os.O_CREAT | os.O_EXCL, 0o640), 'wb') as f:

    FileNotFoundError: [Errno 2] No such file or directory:


    Original exception was:

    Traceback (most recent call last):

      File "/usr/bin/openlp", line 27, in <module>

        from openlp.core.common import is_win, is_macosx

      File "/usr/share/openlp/openlp/__init__.py", line 26, in <module>

        from openlp import core, plugins

      File "/usr/share/openlp/openlp/core/__init__.py", line 43, in <module>

        from openlp.core.ui.mainwindow import MainWindow

      File "/usr/share/openlp/openlp/core/ui/mainwindow.py", line 29, in


        from distutils import dir_util

    ImportError: cannot import name 'dir_util'

  • I helped advice from a neighboring topic for Ubuntu 20:

    sudo apt install python3-distutils
  • instalé la versión 2.4 y me encimaba las letras, me sugirieron en estos foros desinstalarla e instalar una versión anterior. Así lo hice y ahora me manda todo este mensaje de error.

    Me urge saber como dejar limpia mi laptop y volver a instalar una versión que funcione.

  • @Victor_Galvan

    Traducción Española: https://translate.google.com

    You are running a very old version of OpenLP (version 2.2.1).

    If you do not have permission to install software, you can use the portable version. You can find the download for the portable version on the website next to the normal download. Although, it would be best to ask your computer administrator to install the software for you.

  • @ninjakiwi

    Yo soy el dueño de la computadora, el detalle es que me lo hace con cualquier versión que instale, no se como limpiar el registro para poder hacer una instalación limpia.

  • @Victor_Galvan

    Traducción Española

    OpenLP upgrades the database containing things like your songs. When you open an older version of OpenLP, it will not be able to read the updated database.

    OpenLP 2.4.6 should have offered to backup your files when you installed it. If you backed up the files, you can use the backup and go back to your older version. If you did not save a backup, then getting the newer version to work might be the easier option.

    I would be happy to help with your issue in 2.4.6 if I can. Because of the language barrier, I don't quite understand what "the lyrics were on top of me" means. If you send a link to the form discussion you mentioned and perhaps a screenshot of the issue I should be able to help.

  • I think he means that the Main Screen appears on startup completely covering the service manager on a single monitor setup so that none of the service manager functions are accessable. My solution for this was to;

    1. Remember what keypress I had assigned to the show desktop function.

    2. Click anywhere on the main OpenLP display so OpenLP has the focus.

    3. Press that key.

    It would be better if on startup OpenLP knows it has a single monitor that it starts with "Show Desktop" true instead of "Show Presentation".

  • I have been dealing with this same issue for the past three weeks. Every time I try to open OpenLP, I get the same fatal error. I have tried uninstalling it, went through the System Edit and deleted or changed the name of each mention of OpenLP, tried reinstalling with a previous version. I just don't know what to do. The last two weeks, I have simply pulled up the songs in Word and dragged them over to the screen to be viewed. Tomorrow we are honoring the Day of the Christian Martyrs. from Open Doors with a video. I am at a loss as to how to restore our program. Can anyone help me?

  • I have had the same problem today.

    Having seen where the configuration is stored in the windows registry, I had a look. One of the entries (media->players) had a value of "@Invalid()".

    I deleted that single entry and the problem was resolved. OpenLP started up normally with all of my configuration except for the media player priority - which was easily reset.

Sign In or Register to comment.