OpenLP 2.9.3 aka 3.0 Beta 2 OFFICIAL DISCUSSION

edited November 2021 in General Support

OpenLP 3.0 Beta 2 has been released! See the announcement here:

Please report findings and bugs. Read this for a guide on how to create a debug log:



  • edited December 2020

    The new version is great. Runs stable for me. Windows 10, 64bit.

    But the remote control (in Browser) is not yet optimal. Webremote v0.9.4

    • The slides are not coming. Remains empty.
    • The stage view remains black.
    • And with the alerts, only the red bar without text appears.

    Is it just me? (Liegt das an mir?)

    Web remote in Android Chrome 87.0.4280.101 Android Browser V12.5.2-go Windows Edge Version 87.0.664.66 (Official Build) (64-bit)

    In the android app the slides runs. But the stage view is black too, and the alerts are without text.

  • I'm seeing an issue with the displays;

    When I click on identify screens it says that my laptop screen is Screen 2 (Primary). the second display is configured as an extended desktop as normal.

    PS the forum wouldn't let me upload the log file openlp.log said it wasn't one of the allowed file types and the gave a list including .log!!!

  • edited December 2020

    I copied my bible "bible.sqlite" into the database "...\Data\bibles\". The software recognizes the bible as Luther bible, but then says that there is no Bible. It doesn't find any content.

  • I've been doing further experimentation on the displays issue I posted about earlier. If I start OpenLP with the second display connected then I get two "primary" displays. If I disconnect the secondary monitor and then reconnect OpenLP detects that the display has changed and configures them correctly. But then as soon as I exit OpenLP and restart I'm back with two primary displays.

    I'm running Windows 10 20H2 on a Surface Pro 4 with a Surface dock to connect the secondary display. BUt I get similar results if I connect the secondary display directly to the laptop.

  • I've tested the new Version with our church laptop. and i have a problem with my display, everything in the openlp window is too big. On my private Laptop everything is ok. I'm running Windows 10 2H2.

    I tried the portable x64 & x32 Version.

    Before I also tried the second alpha there was the same problem.

    Here is picture of my issue:

  • We hadn't released the web remote. I just pushed the release through now, so you should be able to check for a new version and upgrade to 0.9.5 which should fix these issues. You might need to restart OpenLP to get it to serve the new remote.

  • edited December 2020

    Oh yes! In Browser it works now all. Thank you. In my opinion, the font size is now much larger than in the old version.

    In the Service we use the app for stageview on a tablet (because that the screen always lights up permanently). But in the app stage view it still doesn't show. Screen remains black with a "Close"-button at the bottom right.

    Maybe it's a small thing to fix it? Thank you for your blessed work.

  • I'm also having trouble with bibles on Beta 1 (OS: KDE Neon 5.20) Tried copying sqlite Bibles from previous version and they show up in the Version dropdown in the Bibles Options tab but when I search for a passage the response is "There are no Bible currently installed". The dropdowns in the Select tab aren't populated either.

    I tried importing an Opensong Bible and the import went fine with the sqlite file appearing in the correct folder but OpenLP still maintains that no Bibles have been installed.

  • edited December 2020

    Super excited about the new version - thank you!

    Beta 1 (OS: KDE Neon 5.20)

    I tried out the video backgrounds feature by copying an existing theme (Blue Burst) to a new theme and adding a video background (small mp4) instead of an image background and then setting the new theme as the global default. I'm using a machine with a single monitor (haven't had a chance to try on our dual monitor setup at church) Here's what happens:

    1. The live window shows the text of the song, but only a plain black background.
    2. When I choose to "View the Presentation" the video background plays but the text of the song does not display at all.
    3. The video background (and in fact any video file whether displayed as a theme background or standalone set item) all flicker continuously. I don't have this problem playing the same files directly through VLC. Have tried installing additional codecs, but still no joy.

    Here's the log:

    qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 5795, resource id: 14681369, major code: 40 (TranslateCoords), minor code: 0

    libva info: VA-API version 1.7.0

    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/

    libva info: Found init function __vaDriverInit_1_7

    libva error: /usr/lib/x86_64-linux-gnu/dri/ init failed

    libva info: va_openDriver() returns 1

    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/

    libva info: Found init function __vaDriverInit_1_6

    libva info: va_openDriver() returns 0

    [00007f4f94c310b0] avcodec decoder: Using Intel i965 driver for Intel(R) Sandybridge Desktop - 2.4.0 for hardware decoding

    qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 17283, resource id: 14681397, major code: 40 (TranslateCoords), m

    inor code: 0

    [h264 @ 0x7f4f94c47200] get_buffer() failed

    [h264 @ 0x7f4f94c47200] thread_get_buffer() failed

    [h264 @ 0x7f4f94c47200] decode_slice_header error

    [h264 @ 0x7f4f94c47200] no frame!

    qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 17656, resource id: 14681413, major code: 40 (TranslateCoords), minor code: 0

    I'm going to assume this is hardware-related and keep digging ...

    Edit: Installed Kubuntu 20.10 instead and the error messages above disappear, but the flickering and other behaviour remains

  • The background video does not start when I come from the "show dark" to the "show presentation".

    I help myself now by not using "show dark button", but first using a blank slide and then displaying the Bible verse with video background.

  • Errors like this is has previously been caused by driver issues. Have you installed the latest drivers from the graphics card vendor?

  • Excited to start testing, one thing I noticed, would it be possible to have a direct fade, without it going blank first then the next slide.

  • Done some initial testing on Ubuntu and so far everything is looking great.

    I note that songselect import doesn't bring chords in but its not a big deal. What is important for us would be to transpose chords on the fly. Is this feature on the roadmap?

    ps. am I able to somehow get notified when new releases are ready?

  • edited December 2020

    Began testing today with 2.9.2 on Windows 10 V2004. Screen positioning is a bit different from 2.4.6 but looks like this version is actually correct and 2.4.6 might have been a bit off.

    Tried to access the main screen via the web remote from another PC on the same net and get requested URL not found. Same happens even if I try from the PC running OpenLP.

    Note - the request (from another system) is definitely getting to the OpenLP PC as you can see from this Wireshark trace:

    In checking through the doc, I looked to be sure it was enabled via Settings-Manage Plugins, but Remote is not shown as an option. This install was done as an upgrade from the previous (beta) version.

    Is it still necessary to activate the plugin? It appears to have all the correct settings in Settings-Remote Interface. (The IP address is correct for the PC it's running on)

  • edited January 2021

    Thanks for your suggested solution, I will update the Intel graphics driver soon. If this doesn't work, I will try the Nvidia graphics card.

    But that also explains why I did not have such problems with Linux.

    I will get back to you as soon as I have done the tests.

  • edited January 2021

    @alsorrell The web remote is now built into OpenLP (not a plugin). It looks like there are a few reasons why you cannot get to the web remote:

    • You need to download it by hitting that check for updates button then the upgrade button in the web remote settings page.
    • Set the server IP address to The IP address is where the server serves to, and is a bit like a wild card.

  • edited January 2021

    Thanks - upgrading solved the remote issue.

    Note that the V3 HTML doc still refers to activating the remote plugin both in Web Remote & Plugin List and Live View sections.

  • 1 - Remote Main does not show video playing on main display. It only shows the first frame of the video as a still. Is this supposed to work (it didn't in V2.4.6 and was hoping V3 would fix). Main use case is allowing for videos within a service where OBS or vMix was picking up OpenLP via the web browser method.

    2 - A theme with a video background does not loop the video. Since I suspect the main thing people would want this for is for a motion background for a song, I think there should be an option (?) when video is selected to loop the video. Currently, if you have a 30second video motion .MOV file (say from CMG), it ends after 30 seconds whether or not the song is completed. As is, this is pretty non-useful (IMHO).

  • Alert text doesn't show - dark red background appears at bottom of screen, but no text. This worked OK in 2.4.6

  • IOS app - IOS 14.2 iphone 6, OLP 2.9.2, remote 0.9.5 on Windows 10 v2004

    Neat , but not doing quite what the 3.0 doc says.

    1- When selecting an item in a service, system immediately displays 1st slide of that item, but app doesn't automatically transition to the Slides

    2-In Service mode, pressing up or down arrows at top generate a "User not authenticated message." even though no authentication ahs been requested in the remote settings.

    3 - Once in the Slides section, the up/down arrows at top right change the slide, but only occasionally change the highlight (gray bar) to signify which verse is being displayed.

    4 - Alerts have the same problem as noted above - no text although the dark red background is displayed.

  • Testing OLP 2.9.2 on Windows 10, Apache Open Office 4.1.8

    Trying to run a Powerpoint .PPTX file. OLP recognizes Impress from Open Office and loads the file successfully. However, it displays the output on the primary (OLP) screen rather than on the secondary. Songs and images from the service appear correctly on the secondary. I also tried this with the current LibreOffice version of Impress and found the same issue.

  • Does Impress display correctly if you run it on it's own? It's been a while but I'm fairly sure it has it's own display config that needs to be set up.

  • edited January 2021


    So happy to test this new version, a good job.

    Here some feedback of my test.

    • Like alsorell, a loop option for video background in theme will be appreciate.
    • the setting of the shadow color in theme seem doesn't work, it still black.
    • The font in stage and chords view is too big (on a smartphone android with a web browser)
    • The android app is working partially. I see the service, can change the song, but a black screen is displayed for the stage view and the live view (no chords view).
    • In the remote control, I prefered the yellow background for the active slide (much more visible which slide is active).
    • I don't understand yet how network stream is working.
    • About the "subject" for the songs, I will prefered to see only the list of the songs on the subjects but it work.
    • I can't see "pictures" in the library

    We waited especially for the chords function. We like the new search engine in the bible and the transition between slides. We are using OLP for about 4 years and we are very happy to see the coming of the 3.0.

    Tested on win10.

    Thank you for your work. God bless you.

    Ps: forgiving me for my english.

  • I figured I would do a clean install (Windows 10) of the beta version rather than have it overwrite data. Maybe that was a mistake. I backed up all my data and settings, then uninstalled 2.4.6. The installation of 2.9.2 seemed to go fine, but the program won't run. No worries, I thought. I'll just uninstall the beta and reinstall the old version. Now, that version doesn't run either. I get the -1 error which seems to be related to settings. I guess there must be settings that didn't get cleaned up when I uninstalled the programs. Any ideas? I might try to go through my registry and delete anything I see that is OpenLP related.

Sign In or Register to comment.