OpenLP 2.9.3 aka 3.0 Beta 2 OFFICIAL DISCUSSION



  • There is a write up on how to downgrade from the Beta back to 2.4.6 and it includes removing the OpenLP folder from the registry and removing the Beta data directory. If you have your backup 2.4.6 data directory you can put that in place of the Beta directory to save yourself time.

  • The install issue is definitely registry-related. I renamed Computer\HKEY_CURRENT_USER\SOFTWARE\OpenLP and then was able to install and run 2.9.2. Now I just need to figure out how to fix the screen size issue.

  • edited January 2021

    I'm not able to find that write-up. I did get 2.9.2 working (I think), I just can't use it because I have the same problem as Sterwe with screen size. I can't access any menu options to try to fix it.

    UPDATE: The oversized display issue might be fixed. I think the problem now is black boxes covering the screen. I think I can see a flash of the correct display each time I start the program.

    ANOTHER UPDATE: I managed to find the menu by clicking near the top left of the screen. Still haven't figured out how to adjust the size of screen items or how to get rid of the black boxes.

    ANOTHER UPDATE: I tried out the web remote access which works great! It's much faster than the old remote access. If I could just fix the display on my laptop, I'll be in good shape. Any suggestions would be greatly appreciated.

  • I haven't seen this myself but do you have a high DPI monitor? Have you in the past changed the DPI settings?

  • edited January 2021

    I do not have a high DPI monitor. I messed around with DPI and compatibility settings earlier today. I can make the OpenLP screen appear even bigger, but I can't make it smaller. My laptop resolution is 1920x1080 on a 13" screen. I have Windows 10 set to 150% (the recommended setting), but I set it at 100% for troubleshooting. I seem to have two choices for the OpenLP display -- really big, or even bigger.

  • Yes, I installed the actual Intel graphics driver (it was released this week), now the problem is solved.

    We've got a Intel UHD 620 Graphics Card in our Church Laptop. Maybe it was Problem with Intel Cards

  • edited January 2021

    Thank you. I also have the UHD 620 chipset. Unfortunately, Intel won't let me install the latest driver because it has not been validated by Lenovo for my computer. I'll have to try to get in touch with Lenovo. The last time I contacted them about out-of-date drivers, I got a huge run-around. Their tech support is not able to communicate with the department in charge of driver validation.

    UPDATE: I manually installed Intel driver and was able to run OpenLP 2.9.2 with no issues.

  • Any ideas about how to fix the spacing irregularity in Bibles with superscript verse numbers? The verse numbers currently cause extra space above the line they appear in. I've played around with the line spacing in themes, but I haven't been able to even out the lines. Another new thing with 2.9.2 is the display of partial verses. My preference would be to revert to the behavior of 2.4.6 where a partial verse would not be displayed at the bottom of the slide but would automatically begin on the next slide instead.

  • Trying to create a Custom Stage view by following the current documentation, but not having any luck.

    Is there a different way to create these views in this version? Any help is appreciated. Thanks

  • The released Beta version was missing the Poll function. The latest development version has the Poll function and does work with the 2.4.6 version stage views with slight adjustments. We are working to get away from the Poll function and towards using a websocket to replace the `Poll` function.

  • I've been really enjoying the new Beta, thank you all for your hard work! I did notice that with the updated remote, my custom stage views that I created for my previous version don't work in the Beta, however they still work in the previous version.

    Will this be updated in the future so we can create our own web views?


  • Yes there will be an update. Version 2.4.6 used polling to update the stage views. There were a lot of issues with this approach. The released Beta did not have the polling feature, but polling has been added to the development versions since the released Beta.

    At some point in the future support for polling will be if you are doing new development on custom stages you should consider using a websocket approach to replace the polling function.

  • I added a new 2nd monitor to my system - the setup I had before was a bit strange. Once the Impress screen setup was set, it performed correctly. Please ignore earlier comments re Impress.



  • Hi,

    We installed now the beta in the church win10 pc. Here some feedback :

    The option to show in preview window the item cliqued one time in the service list is a good idea, but for videos, an option will be welcome to not start the playing in the preview.

    We can see the video playing in the preview window, but not in the direct window (never).

    The sort of the list in the media library is strange, no way to get it well. We have a lot of videos named with a number and a name like this :


    Until 270, and we don't have the good sort. It's very uncomfortable.

    This post to complete my first one.


  • Hi,

    Great to see the new beta. However, I'm having problems getting it going on my iMac running macOS 10.15.7. When I try to start the software I get a warning saying "There is a mismatch between screens and screen settings. OpenLP will try to automatically select a display screen, but you should consider updating the screen settings."

    The software then just hangs and needs a Force Quit. I have a second screen connected to the iMac via a USBC to HDMI dongle so I tried turning that off but still the same issue. Without it starting, I cannot change the screen settings.

    I tried running with from the command line with the debug function and got the following text in Terminal

    Logging to: /Users/paulwilton/Library/Application Support/openlp/openlp.log

    Qt WebEngine resources not found at . Trying parent directory...

    Qt WebEngine resources not found at /Applications/ Trying application directory...

    Installed Qt WebEngine locales directory not found at location /qtwebengine_locales. Trying application directory...

    Setting up log file: /Users/paulwilton/Library/Application Support/openlp/libreofficeserver.log

    Traceback (most recent call last):

     File "/Applications/", line 46, in <module>

      from serializers import register_classes

     File "/Applications/", line 24, in <module>

      from openlp.core.common.path import Path

    ModuleNotFoundError: No module named 'openlp'

    qt.qpa.fonts: Populating font family aliases took 222 ms. Replace uses of missing font family ".SF NS Text" with one that exists to avoid this cost.

    Any ideas?



  • Custom Stage Views and OpenLP Beta 2.9.2

    There is now a custom stage.js file that will allow the current Beta to run custom stage views. The new file replaces the polling function with a web-socket function and uses the new version of the API.

    The file is located here.

  • edited February 2021

    EDITED 2/9/21

    V2.9.2 problem with theme text with outline - outline is much thicker than in 2.4.6 - not honoring font selection?

    Using the same theme on a 1280x720 output screen, the outline thickness is MUCH thicker (unusable) under 2.9.2 (Windows 10 20H2 19042.746). Note: This thickening only occurs when the text has the BOLD {st} attribute, but spacing is messed up regardless. Theme export included in ZIP file.

    Text font is CMG Sans Medium 40pt. with 1 pt outline; Footer is CMG Sans Extra Light 8pt. As you can see in the pictures below, the spacing is off and I'm not sure the fonts are the same. Fonts are .ttf and the directory failed to attach. They can be downloaded for free from

    Screenshots - top is V2.9.2, bottom is V2.4.6

  • V2.9.2 on Windows 10 20H2 Unable to enter negative geometry coordinates for single screen

    In OpenLP 2.4.6 on Windows 10, it was possible to create a "phantom" screen by using the geometry override on a single screen system. This allowed the use of the web remote to pass the image to a program such as OBS or vMix from a single-screen system such as a laptop without taking over the controlling screen. I haven't been able to find a way to do this in V2.9.2. Is there a way to achieve the same effect under V2.9.2?

  • @alsorrell I am looking at your Font Outline issue. Can you verify that you only have the font outline enabled and do not have the font shadow enabled? Working on the assumption that you do not have the font shadow enabled, I think I can see the same issue on other fonts....makes it easier to duplicate and takes the blame away from the specific font....but that does not mean it is easier to fix!

    I'll open an issue if one isn't already open so this can get some attention.

    Thanks for letting us know.....I would never have seen this as my fonts are mostly double the size you use.

  • We've been using the Beta for several weeks and have been very happy with it. The only weird thing we're seeing is that PDFs are not sizing to fit the screen (see below). My resolutions are at 1920x1080. I don't remember this being a problem in 2.4.6. Right now, I'm compensating by reducing my screen resolution down to 720 and that helps but then I have to adjust font sizes in my themes. Thanks for all the dedication to this project!! God Bless!!

  • edited February 2021

    @ohn M -

    Yes - only font outline is on, no shadow - but please also notice the large discrepancy in the spacing as well.



  • edited February 2021

    Song window is not properly sorted in V2.9.2

    OpenLP 2.9.2 on Win 10 V20H2

    V2.4.6 sorts the song list window correctly by title. V2.9.2 does not, even after a Tools->Songs->Re-Index. V2.9.2 was done as an upgrade over 2.4.6



  • @alsorrell Did you try the Title search in Songs? And does it do the same thing?

  • I used to use the Custom Stage aswell for ou livestreaming for the Bibles, and now I can't. Could you please put the function back. Also how and where do we put the Custom View as it used to be in the plugins directory.

Sign In or Register to comment.