OpenLP 2.9.3 aka 3.0 Beta 2 OFFICIAL DISCUSSION



  • OpenLP 2.9.2 aka 3.0 Beta 1 won't run on my MacOS Mojave, MacBook Pro 15" mid-2014 model. After launch, nothing but the Name in top bar next to Apple symbol, and program is "not responding".

    Anyone else having success with Mojave?



  • Hey John,

    I finally did get the transitions to work on the portable version. It does seem a bit hard to get to work at first. How do I get the Bible to import into the portable on WIndows 10 loaded on my desktop. I have tried download, import an opensong file but none will show in the program. The file is in the data folder of the portable app.

  • Trying to save a service on my thumb drive and keep getting this messag in portable 2.9. It will save on desktop but trying to make it easy to move portable app and service files.

  • @ebowen The first thing I would suggest is not to put anything in the OpenLP Data directory. The data directory is not a safe directory....the system owns and manages this directory and stuff goes missing from this directory from time to time.

    To import the OpenSong song you should put the file someplace on your computer, then start OpenLP from the USB drive and use the import function on the File menu to import the song. Remember to select the OpenSong file type and add the file to the importer. IF this does not work it may be a bug on the portable version.

    For the service file, try to save it to the F:/ directory or to your PC documents directory...I am trying to see if it is an issue with the directory you are trying to us or if the portable unit has an issue.

    Keep us posted!

  • aboabo
    edited March 2021

    Sorry to answer so late. I am retired but even busier than when I was working.????

    The same problem occurs with OpenLP in English or French. It does not seem to be related to the selected language.

    An example of an imported chordpro file is attached.

    There is no error reported during import.

  • Hey John

    The Opensong import was for the Bible. I downloaded the KJV and tried to import it. It imports but will not show up in the bible tab. It says no Bibles downloaded but it is in the data/bible folder. How can we import or download a Bible onto drive instead of online version from webdownload? I can get my imported opensong bible to pull up content if I download online Bible into data file. If I delete the 52kb file my imported Bible will not get recognized.

    I tried saving to usb drive root and no go.

  • @ebowen Sorry for my misunderstanding. There is a bug that causes an error about no bible being loaded....If you go into the options tab of the Bible library and select a Bible, yes I know it already has a Bible selected so humor me and select a different Bible. Then go back to the search tab of the same Bible Library you should be able to find this point you can go select the Bible you want and everything should be good.....not sure if what you are seeing is the same bug, but it cant hurt to see if this fixes the issue.

  • John,

    I downloaded an opensong bible KJV and imported it into OpenLp portable. It shows but wont recognize it, I only have it loaded. I tried the option but it will not work with one Bible imported. I restarted and it still shows no chapters or verses.

  • Just did my first live service with 2.9.2 yesterday. Two things I noticed.

    One was that the desktop background sometimes appeared for a second or so before a video starting. Not catastrophic but distracting.

    The second was the "Theme" shortcut key which, I'm sure, used to be a toggle. This time when I switched to display theme only I could only get the display back by clicking the "show presentation" icon under the "Live" window on the main display. That was embarrassing!

    Clicking the icon reminds me of another outstanding issue - the tiny font (and icons) on the main, controlling screen. While the projected (extended desktop) screen is fine, after fiddling with theme settings to suit the projector in use, the text on the operator's screen is tiny except for song titles and other content. This has been a problem since moving to at least 2.4, maybe longer.

    Hope these comments are useful.

  • @cameronag You're right that the theme, blank and desktop buttons are no longer toggle buttons. You can blame me for that change; it is to reduce confusion with how OpenLP works: You cannot overlap the different modes, it is only ever one of them (live, black, theme or desktop). All the modes have these default shortcuts:

    • Live - Spacebar
    • Black - Full stop
    • Theme - "T"
    • Desktop - "D" or Escape

    So to get the display back, you can hit the spacebar. (Works from any mode)

    Perhaps it may take a little getting used to, but I think it's better for a shortcut to not depend on the state of OpenLP. With this setup, spacebar will always show the display, and "." will always hide it.

    I know the interface isn't huge, but I wouldn't call it tiny. Perhaps we could add a interface scale option in the settings in the future... Could you send a screenshot just to check it's normal?

  • I noticed the showing desktop issue and worked around it by changing my background to solid black. would rather it didn't happen though.

  • @cameronag @NLACav

    I can seem to replicate your showing desktop issue. Could you find out if the "Transition between service items" option under `Settings -> Themes -> Universal Settings` is enabled? And after switching it, do you still get the issue?

  • I have tried with that option both on and off. Still get the desktop for a split second. Before the latest windows update it was a longer time (~1-1.25 secs vs ~0.75 secs now) but is now usable. I can probably get a video of the issue if needed as we live stream and I have a capture card for the lyrics computer. I posted a log earlier in this thread that I pulled when it was doing the issue.

  • I encountered the flickering video too. Although I would not call it flickering, rather it is flashing white about 3 times a second irregularly. Looks like openlp and the window manager are fighting over who gets to be on top. I got rid of that by enabling "override window manager" in the configuration widget.

    I am on Ubuntu 20.04, using gnome3.

  • Here is how i got video backgrounds to work properly on Ubuntu 20.04 (Gnome 3):

    • check "Bypass X11 window manager" in settings/Advanced (gets rid of white flashing)
    • encode video to motion jpeg using ffmpeg (without this the video stops after 2 loops)

    Otherwise: Great progress. I like that the performance of web clients now is usable, in 2.4 I saw latencies of 10 seconds over a stable wifi connection. Also the deuglyfication of the icon set is commendable.

  • I am still having problems getting the transitions to work consistently in Open LP portable , windows 10 with a folder of images playing in a loop. I have set up custom theme with transitions and it just cuts to next slide. Im guessing this is bug. Does this work properly in desktop windows 10 version? Anyone using windows tried this?

  • Just a heads up - after the latest driver/windows updates it seems to work as intended without the desktop showing when we don't want it.

  • Is anyone else using Bitfocus Companion with OpenLP?

    We have companion set up doing various things, and use the OpenLP plugin on it which gives control over blank/theme/desktop etc from buttons on our streamdecks.

    I tried the 2.9.2 beta, and as soon as OpenLP is running it crashes Companion - I've replicated this on two different setups.

    Just wondering how to start on getting this resolved, as want to help out! I know that companion uses the http api - has that changed in 2.9.2?

  • @Chippie The Http API did change and the Beta is missing parts of the original API. For backward compatibility the Original API has been worked on, but until the next Beta release you may have issues using the original SPI. The new API is documented on the OpenLP Wiki

  • +1 on this. We tend to use only one translation but it's annoying to have to switch tabs to change if we need to. Previous version had that part right (every other change to bibles is an improvement as far as I can tell)

  • Is 2.9.2 now considered stable enough for live use?

  • Been using it for a couple months. No show stopping bugs that I have found. Make sure to back up all your data before updating and read this thread completely so you know what to expect and what the solutions to common problems are.

    And don't test in production. Give yourself a few days to test it before using it in a service.

  • I have been trying OpenLP out for possible deployment. I started with 2.9.2 (beta) but have since shifted to the git code[1] since some things have been fixed since 2.9.2 was released. I have encountered a number of issues which I thought I'd jot down to see which - if any - have known solutions. I am running OpenLP on Slackware64-current with python 3.9.5, Qt 5.15.2, Libreoffice 7.1.2 and VLC 3.0.12. The following list is in no particular order and, as far as I can tell, affects the beta as much as the git code.

    1. When playing an audio media file the projection screen goes totally white. This happens even if I've explicitly defined a theme which has black as its background. If a fixed colour is to be shown during audio playback I would have expected it to be black. I can't find any OpenLP setting related to this. Is it perhaps a setting in VLC?
    2. When an audio or video media file is played the timeline widget remains at 0:00, the position indicator remains at the start and clicking anywhere on the timeline has no effect. Is the timeline meant to work at this point in time?
    3. To get OpenLP to use Libreoffice to support presentations, I needed to set some environment variables: PYTHONPATH=/usr/local/libreoffice/program/, . It was then possible to load an ODP presentation into the library. When I go to insert this into a service, I get a "Missing Presentation" error dialog: "The presentation <FILENAME> is incomplete, please reload." The presentation is not inserted into the service.
    4. When closing OpenLP some xcb errors are displayed on the console[2].

    A debug log is attached for the following sequence of events:

    • Start OpenLP.
    • Select Presentations from the library
    • Double-click an ODP presentation file to add it to the service
    • Click "Ok" in the error dialog box
    • Exit OpenLP

    Does this provide any indication as to what the error might be? I'm seeing some errors ("ERROR"), including some related to UNO, but it's hard to tell whether they are related to the difficulties with presentations because I don't know what the expected behaviour might be. I see some errors linked to stack depth but again I can't tell if these are significant or not.

    I'm happy to run additional tests or provide extra information if it would help track the issues down. Given the lack of any similar reports on the forums that I can see,

    I suspect that there may be local issues at play. If so, hopefully the cause can be identified easily so I can continue evaluating OpenLP for our use.

    [1] Git pull is current as of this writing (8 June 2021).

    [2] qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 2430, resource id: 4202265, major code: 40 (TranslateCoords), minor code: 0

    qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 2619, resource id: 4202353, major code: 40 (TranslateCoords), minor code: 0

  • I love the OpenLP 2.9.2

    I have some YouTube settings that working great. Depending on a 2K (1920x1080) or a 4K (3840x2160) overhead projector, I have made an entire set of Themes for 2K and 4K. Even 2K and 4K Themes for YouTube and they work great. I also have 2K and 4K Themes for Images, Responsive Scripture Readings, Songs, and Bible Verses. There are a few bugs I'll report later, but in general it is a good product. I'm setting up Training overheads in 2K and 4K also.

    Johnny Fowler


  • Is it possible to edit the stage view? Would like to make it more simple with just the current slide and the time on it. Not a Programmer or I would dig into the html/css.

Sign In or Register to comment.