Segmentation Fault in Kubuntu 18.04


  • 'Hi. I also have just come across the 'Segmentation fault (core dumped)' problem. I am running Kubuntu 18·04, and it was working fine last week. Now I just get the splash screen, which promptly disappears, and the program, then hangs.
    Any help would be appreciated, obviously  :) 

  • @Zierl Did you do any software updates recently?
  • I usually do all the updates that are suggested for Kubuntu, but I haven't done anything additionally. 
    This time, I started it from Konsole initially, rather than from the widget.

    The error message on this first attempt was:
    libpng warning: iCCP: known incorrect sRGB profile
    libpng warning: iCCP: known incorrect sRGB profile
    free(): invalid pointer
    Aborted (core dumped)

    It was only a subsequent run attempt that produced
    libpng warning: iCCP: known incorrect sRGB profile
    libpng warning: iCCP: known incorrect sRGB profile
    Segmentation fault (core dumped)

    I am in well over my head here

  • (I just split this into its own discussion, it was wondering off topic from the previous one)
  • Yeah, we've been having some issues with the underlying libraries that OpenLP uses (which are the same libraries that Kubuntu uses), but none of the issues we've seen have shown up during runtime.

    Maybe try backing up your data and your config, and starting OpenLP again? This shouldn't make a difference, but it at least helps us remove the data from the list of potential problems.
  • Hi @Zierl and @david_e_craddock

    Since we don't know why OpenLP is crashing, it is hard for us to debug this issue. But I have an idea that, if we're lucky, might help. OpenLP has "plugins" that handles image, songs, presentations, media etc, and maybe the crash is triggered by one of the plugins. If so OpenLP should start id the plugins are disabled.
    To disable the plugins open the following file in a text editor (such as gedit or kedit): /home/tgc/.config/OpenLP - /OpenLP.conf   - replace "tgc" with your own user name.
    In that file you will see the settings for OpenLP. Each section starts with "heading", like this "[songs]", which is the settings for songs. And for each plugin-section you will find a settings saying "status=1". By changing that to "status=0" that plugin will be disabled. So change status for plugins and save the file. Start OpenLP, and if it starts, try enabling the plugins one by one. If OpenLP does not start with all plugins disabled, we will atleast have ruled out the plugins as the problem...
    Please report back your findings!
    Best of luck!

  • HI. Sadly, I have disabled all the plug-ins, but still got the result: 
    libpng warning: iCCP: known incorrect sRGB profile
    libpng warning: iCCP: known incorrect sRGB profile
    free(): invalid pointer
    Aborted (core dumped)

    It is certainly a bit of a puzzle :(
  • Hi @Zierl and @david_e_craddock 
        Lets take this one step further....Make a backup of your data....See the manual if you have questions  Be sure your backup is not in the Data directory! A thumb drive, network drive or even you documents directory are good places to put your backup for what we are trying to do...

    1.    After you have made your backup, open a file explorer window to the Data directory....Same way you did it when you backed up your Data directory. 
    2. Make sure OpenLP is closed. Then delete all the folders in the Data directory.....As long as your backup was made, you don't have anything to worry about!  You can copy the backup into the data directory when we are done!
    3. Launch you still see the errors?  
    If you still see the errors than let us know.

    If don't see any errors;
    1. Try copying 2 folders at a time from your backup into the data directory....remember to shut down OpenLP before you copy into the Data directory....and make sure you are only doing a COPY....
    2. When you see the errors, delete the 2 folder from the Data folder that you copied last.
    3. Copy one folder at a time into your Data directory....
    4. Let us know what folder caused the errors to start happening.
  • I tried all suggestions. I even deleted all the Data folders, uninstalled and reinstalled OpenLP and still the program would not open. I am at a loss as to what the problem is. I will wait on the experts to do the next version to fix the issue. I know it can be a problem when the operating system makes changes that affect the software that then needs addressing.  Thanks for the suggestions and effort.
  • David you could try running a virtual Windows machine and running OpenLP in the virtual Windows machine.....if you can't wait...
  • edited August 2019
    Hi @david_e_craddock , I've tried to reproduce your error on a brand new installation of Kubuntu 18.04, and I can't seem to do it :frowning: Could I ask you to send me a list of all the installed packages on your system?

    From the command line:
    apt list --installed > installed.txt
    Then either upload the file here, or if you'd prefer I can reach out to you via e-mail, and you can send it to me.
  • Hi @david_e_craddock
    A way to track down the root cause is also to run OpenLP in a debugger.
    First you'll need to install the debugger : "sudo apt install gdb"
    Then run it: "gdb --args /usr/bin/python3.6 /usr/bin/openlp"
    This will start the debugger console, enter "r" and push enter to run OpenLP.
    OpenLP will then try to run and when it crashed you can enter "bt" into the debug console to get a traceback.
    Getting the complete output from the debugger would be helpful!
  • edited November 2021

    Hi @tgc and @raoul

    I'm having the same issue, but i'm on PopOS 21.04.

    I ran the debugger as tgc suggested:

    @pop-os:~/.config/OpenLP$ gdb --args /usr/bin/python3.9 /usr/bin/openlp 
    GNU gdb (Ubuntu 10.1-2ubuntu2)
    Copyright (C) 2021 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.
    Type "show copying" and "show warranty" for details.
    This GDB was configured as "x86_64-linux-gnu".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    Find the GDB manual and other documentation resources online at:
    For help, type "help".
    Type "apropos word" to search for commands related to "word"...
    Reading symbols from /usr/bin/python3.9...
    (No debugging symbols found in /usr/bin/python3.9)
    (gdb) r
    Starting program: /usr/bin/python3.9 /usr/bin/openlp
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib/x86_64-linux-gnu/".
    [Detaching after fork from child process 15929]
    [Detaching after fork from child process 15930]
    [Detaching after fork from child process 15931]
    [Detaching after fork from child process 15934]
    [Detaching after fork from child process 15935]
    [New Thread 0x7fffe90cb640 (LWP 15936)]
    [New Thread 0x7fffe3a6c640 (LWP 15937)]
    [New Thread 0x7fffe326b640 (LWP 15938)]
    [New Thread 0x7fffe2a6a640 (LWP 15939)]
    [New Thread 0x7fffe207e640 (LWP 15940)]
    [New Thread 0x7fffe1859640 (LWP 15941)]
    /usr/share/openlp/openlp/core/utils/ FutureWarning: Possible nested set at position 1
      if re.match(r'[[].*[]]', language):
    [New Thread 0x7fffc9f44640 (LWP 15944)]
    [New Thread 0x7fffc9743640 (LWP 15945)]
    [New Thread 0x7fffc8f42640 (LWP 15946)]
    [New Thread 0x7fffc3fff640 (LWP 15947)]
    [New Thread 0x7fffc37fe640 (LWP 15948)]
    [New Thread 0x7fffc2ffd640 (LWP 15949)]
    [New Thread 0x7fffc27fc640 (LWP 15950)]
    [New Thread 0x7fffc1ffb640 (LWP 15951)]
    [New Thread 0x7fffc17fa640 (LWP 15952)]
    [New Thread 0x7fffa7fff640 (LWP 15955)]
    --Type <RET> for more, q to quit, c to continue without paging--c
    Thread 1 "python3.9" received signal SIGSEGV, Segmentation fault.
    0x00007fffa7203035 in ?? () from /usr/lib/x86_64-linux-gnu/dri/
    (gdb) c
    Couldn't get registers: No such process.
    Couldn't get registers: No such process.
    (gdb) [Thread 0x7fffa7fff640 (LWP 15955) exited]
    [Thread 0x7fffc17fa640 (LWP 15952) exited]
    [Thread 0x7fffc1ffb640 (LWP 15951) exited]
    [Thread 0x7fffc27fc640 (LWP 15950) exited]
    [Thread 0x7fffc2ffd640 (LWP 15949) exited]
    [Thread 0x7fffc37fe640 (LWP 15948) exited]
    [Thread 0x7fffc3fff640 (LWP 15947) exited]
    [Thread 0x7fffc8f42640 (LWP 15946) exited]
    [Thread 0x7fffc9743640 (LWP 15945) exited]
    [Thread 0x7fffc9f44640 (LWP 15944) exited]
    [Thread 0x7fffe1859640 (LWP 15941) exited]
    [Thread 0x7fffe207e640 (LWP 15940) exited]
    [Thread 0x7fffe2a6a640 (LWP 15939) exited]
    [Thread 0x7fffe326b640 (LWP 15938) exited]
    [Thread 0x7fffe3a6c640 (LWP 15937) exited]
    [Thread 0x7fffe90cb640 (LWP 15936) exited]
    Program terminated with signal SIGSEGV, Segmentation fault.
    The program no longer exists.
  • @DanteCoder Hrm, it looks like the segfault is happening in your video card driver. Unfortunately the output you have there doesn't seem to say much else. If you run it again, try typing "bt" after the segfault, that'll produce a trace, which might help us further narrow down the problem.

    It will probably also be helpful to have the "-debug" packages installed for Python, PyQt5 and Qt5.

  • @raoul here is the output after the segmentation fault (I cant post too long comments):

    Thread 1 "python3.9" received signal SIGSEGV, Segmentation fault.
    0x00007fff62e03035 in ?? () from /usr/lib/x86_64-linux-gnu/dri/
    (gdb) bt
    #0  0x00007fff62e03035 in  () at /usr/lib/x86_64-linux-gnu/dri/
    #1  0x00007fff62df443f in  () at /usr/lib/x86_64-linux-gnu/dri/
    #2  0x00007fff62ddaf65 in  () at /usr/lib/x86_64-linux-gnu/dri/
    #3  0x00007fff62fe3579 in  () at /usr/lib/x86_64-linux-gnu/dri/
    #4  0x00007fff62fe7ab3 in  () at /usr/lib/x86_64-linux-gnu/dri/
    #5  0x00007fff62fe7eb2 in  () at /usr/lib/x86_64-linux-gnu/dri/
    #6  0x00007fff62fae7f2 in  () at /usr/lib/x86_64-linux-gnu/dri/
    #7  0x00007fffc820c400 in vaPutImage () at /lib/x86_64-linux-gnu/
    #8  0x00007fffc0ed4d92 in  () at /usr/lib/x86_64-linux-gnu/gstreamer-1.0/
    #9  0x00007fffc0e94f39 in  () at /usr/lib/x86_64-linux-gnu/gstreamer-1.0/
    #10 0x00007fffc0ea3400 in  () at /usr/lib/x86_64-linux-gnu/gstreamer-1.0/
    #11 0x00007fffec699616 in  () at /lib/x86_64-linux-gnu/
    #12 0x00007fffec587769 in gst_element_change_state ()
        at /lib/x86_64-linux-gnu/
    #13 0x00007fffec587e7d in  () at /lib/x86_64-linux-gnu/
    #14 0x00007fffc870c20c in  () at /lib/x86_64-linux-gnu/
    #15 0x00007fffc870b37d in QGstreamerVideoWindow::QGstreamerVideoWindow(QObject*, QByteArray const&) () at /lib/x86_64-linux-gnu/
    #16 0x00007fffe0016d9f in  ()
        at /usr/lib/x86_64-linux-gnu/qt5/plugins/mediaservice/
    #17 0x00007fffe001aa55 in  ()
        at /usr/lib/x86_64-linux-gnu/qt5/plugins/mediaservice/
    #18 0x00007ffff086e9ff in  () at /lib/x86_64-linux-gnu/
    #19 0x00007ffff08ad4ff in QMediaPlayer::QMediaPlayer(QObject*, QFlags<QMediaPlayer::Flag>)
        () at /lib/x86_64-linux-gnu/
    #20 0x00007ffff09a529d in  () at /usr/lib/python3/dist-packages/PyQt5/
    #21 0x00007ffff09a5398 in  () at /usr/lib/python3/dist-packages/PyQt5/
    #22 0x00007ffff3a663d0 in  ()
        at /usr/lib/python3/dist-packages/PyQt5/
    #23 0x0000000000521bc5 in _PyObject_MakeTpCall ()
    #24 0x000000000051b9f8 in _PyEval_EvalFrameDefault ()
    #25 0x0000000000514a75 in  ()
    #26 0x000000000052d302 in _PyFunction_Vectorcall ()
    #27 0x000000000053bf05 in  ()
    #28 0x0000000000521bc5 in _PyObject_MakeTpCall ()
    #29 0x000000000051b595 in _PyEval_EvalFrameDefault ()
    #30 0x0000000000515377 in  ()
    #31 0x000000000052d302 in _PyFunction_Vectorcall ()
    #32 0x0000000000540211 in  ()
    #33 0x00000000005181b6 in _PyEval_EvalFrameDefault ()
    #34 0x0000000000514a75 in  ()
    #35 0x000000000052d302 in _PyFunction_Vectorcall ()
    #36 0x0000000000516543 in _PyEval_EvalFrameDefault ()
    #37 0x000000000052d163 in _PyFunction_Vectorcall ()
    #38 0x000000000054015f in  ()
    --Type <RET> for more, q to quit, c to continue without paging--
    #39 0x000000000051b3ac in _PyEval_EvalFrameDefault ()
    #40 0x000000000052d6cf in _PyFunction_Vectorcall ()
    #41 0x000000000051635b in _PyEval_EvalFrameDefault ()
    #42 0x0000000000514a75 in  ()
    #43 0x000000000051480b in _PyEval_EvalCodeWithName ()
    #44 0x00000000005fb257 in PyEval_EvalCode ()
    #45 0x00000000006205fb in  ()
    #46 0x000000000061b724 in  ()
    #47 0x000000000061fb2d in  ()
    #48 0x000000000061f63a in PyRun_SimpleFileExFlags ()
    #49 0x0000000000613527 in Py_RunMain ()
    #50 0x00000000005ef7fd in Py_BytesMain ()
    #51 0x00007ffff7c21565 in __libc_start_main (main=
        0x5ef7c0, argc=2, argv=0x7fffffffe0d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffffe0c8) at ../csu/libc-start.c:332
    #52 0x00000000005ef6fe in _start ()
  • @DanteCoder Thanks, that's more helpful. It still looks like an issue somewhere between your video card drivers and the multimedia system in Qt that OpenLP uses. I'll have to take a deeper look at this.

  • @DanteCoder by the way, which version of OpenLP are you using?

  • edited November 2021

    @raoul Hmm

    Thank you! I'll be very grateful, as i'm migrating the church's pc to linux and openlp is the only program that gave me some problems. For now i'll use a virtual machine to get around this, but as i'm using obs-studio to live broadcast openlp on a second screen, using it natively on linux would be great.

    lorena@lorena-linux:~$ apt-cache policy openlp 
      Installed: 2.4.6-1
      Candidate: 2.4.6-1
      Version table:
     *** 2.4.6-1 500
            500 hirsute/universe amd64 Packages
            500 hirsute/universe i386 Packages
            100 /var/lib/dpkg/status
  • Good day,

    How do I change this display settings, currently when I display verses I get one word per slide. See attached picture

    Can I get help please,

    Thank you

  • @Mmakwena wow that's pretty weird actually. I think that is some error when importing the bible, but you can ask in the proper place to get a better answer. This discussion is for a specific technical problem, as you can see on the comments above.

    Try searching if anyone had the same issue like you, and if you don't find anything, you can create a new post here:

  • Similar "segfault at" ... "error 4 in" with "CometLake-S GT2 [UHD Graphics 630]" and Ubuntu 21.10 intel-media-va-driver 21.3.3+dfsg1-1.

    No such segfault after

    sudo apt install intel-media-va-driver-non-free

    with intel-media-va-driver-non-free 21.1.1+ds1-1.

  • @DanteCoder OpenLP 2.9.4 was released recently, and I recommend taking it for a spin. You down download the deb file from the blog post.

  • Indeed this apparently resolves the "segmentation fault" issue. Thank you.

    I also had to run

    apt install ure-java

    because I had this warning:

    Warning: failed to launch javaldx - java may not function correctly

Sign In or Register to comment.