OpenLP 2.9.2 or 2.9.3 will not open on macOS Monterey Version 12.1

OpenLP 2.4.6 runs fine under macOS Monterey version 12.1. When I tried to upgrade to either version of openLP (2.9.2 or 2.9.3) I get a dialog box letting me know my OpenLP is being upgraded and if I want to back up the old database. After answering those two dialog boxes I get the splash screen with the OpenLP logo and that is it. The program hangs and I have to force quit it. I have been combing through all of these discussion boards and can't find anyone else having this issue. Not sure if anyone else has upgraded their macOS's to the latest version. I did read one thread which suggested opening the and drilling down and deleting the 'presentation' folder under plugins. I believe they were helping someone downgrade their installation of openLP. I decided to try this and it worked. OpenLP 2.9.2 and 2.9.3 loaded but didn't have any songs, bibles, themes etc and when I tried to re-run the first time wizard, both versions displayed 'oops we've run into a problem'. I put back the folder under 2.9.3 while it was running, and I got my songs, bible etc back, but when I tried to re-run the first time wizard the program displayed the 'oops we've run into a problem'. Also when trying to send a bible search to the 'service' window the program displays the 'oops we've run into a problem'. I can send anything else to the 'service' window just fine. If I delete the file '' from the package the program loads and runs but again with the same problems as mentioned before. Also when I delete the file just to get the program to load all of the floating text boxes don't show any text in them. Any thoughts on what I can do to get this to load would be great.


  • It's not hanging, that's the display screen. Just try clicking it a couple times, and pressing Escape, and it should disappear. Then go into OpenLP -> Preferences -> Screens and untick "Display if single screen".

  • edited December 2021

    Thank you for the reply, but it is not just the display screen. When I right click on the openlp icon in the dock it shows the program is not responding. Also when I right click on the icon in the dock and click on 'show all windows' I get the message 'no available windows'. As I mentioned before, if I delete the '' from the file the program loads, with the errors mentioned before. I also have made sure the "Display if single screen" is unticked. I have even unticked "Show the Splash Screen" and check for updates, to no avail.

Sign In or Register to comment.