Cannot search media in openlp 2.9.3 via the iOS app

When I try to search for media using the OpenLP app for iOS, I get an error message saying, 'error occurred try again' . I am assuming it has something to do with the folders option in 2.9.3. I can search the media just fine in 2.4.6. Does anyone know if this will be fixed in an update for the app.


  • We released a new remote API in OpenLP 2.9.x, though we tried to maintain backward compatibility. You can try using the new Web Remote in 2.9.x which should hopefully also be more responsive than the iOS app. Just make sure to check the IP address in OpenLP.

  • The web remote doesn't allow me to search the custom slides, media, images or presentations. It will show the list of songs but only after I put something in the search criteria and the "User Authentication" under the Remote Interface settings must be unchecked. I don't know how to get web remote to send user ID and password to authenticate someone. The online manual doesn't talk about configuring the web remote. I have tried to use the web remote on a different device just to make sure there wasn't some issue with using web remote on the same computer running OpenLP with the same results, not being able to search the affore mentioned categories.

  • Custom slides are working for me, but I see there's an issue with media. I'm looking into it.

  • I got a fix for this, it'll be in the next release.

Sign In or Register to comment.