OpenLP 2.9.4 aka 3.0 RC1 OFFICIAL DISCUSSION

124678

Comments

  • Hey Raoul,

    Did you ever figure out why the transitions are not working for group images in the newest version?

  • @ebowen

    Did you ever figure out why the transitions are not working for group images in the newest version?

    I did. However fixing it is another story... it's kinda complicated.

  • I'm running openlp on linux in a virtualenv, and none of the rendering works:

    Theme thumbnails, live previews, even the list of song elements above the previews are all blank.

    Any ideas? I tried running from git and from the tarball.

  • edited March 2022

    Has anybody figured out correct syntax for custom formatting tags for align center, align left and align right? The ones in the manual do not work in 2.9.4. I have tried a number of html and css strings and nothing works.

  • @Bennett

    I'm running openlp on linux in a virtualenv, and none of the rendering works

    I've only briefly tried running OpenLP in a virtualenv. Which distro are you using?

  • Hi,


    OpenLP 2.9.4

    Web remote 0.9.7 without authentication

    Windows 10


    I have been struggling for several days to control OpenLP via API v2.

    No problem with GET requests.

    But I can't figure out how to pass arguments for POST requests.


    I tried directly in the url for example .../controller/progress?request={"action": "next"} or .../controller/progress?data={"action": "next"} or .../controller/progress?data={"request":{"action": "next"}}

    I tried with and without url encoding .

    I tried placing the arguments in the body of the request.

    ... still without success.


    The answers are either 400 Bad Request or 404 Not Found.


    I use Invoke-RestMethod under Powershell and I successfully control several other applications without any problem.


    Is it a bug in 0.9.7 ?

    What is the right method?

    Where are stored the web server logs? There is no trace in the OpenLP logs even in debug mode.


    Thanks for your help.

  • Hi, many thanks for your help. You gave me more than expected as the sample provides information for api v1 and v2.

    Have a good day.

  • We are having trouble with the transition to black. If we show a song, then the Desktop, and then Black we get a wired transition, where the song is shown again before transitioning to black. If we change the song while showing the desktop and then switching to black, we briefly see the first song, then the newly selected song, and then the transition to Black.

    We encounter the problem on Windows 10 (Nvidia v456.71). Are we the only ones or can some of you recreate this bug?

  • @Pumba it sounds like you're experiencing this bug:

    In which case, it has been fixed and will be part of the next release.

  • Is it reasonable to assume that if image files are in alphanumeric order on my computer (when I've created them) that they'll stay in that order once imported into OLP?

    I think it is a reasonable assumption to make, but I'm interested to know what others think.

    My question is prompted by a whole lot of imported files which were meant to stay in order but, unfortunately, haven't stayed that way when imported to OLP. This has been happening for the past few weeks. Prior to then, I don't recall ever having encountered such a problem.

    I create image files (in Keynote) for our Bible readings because I have better and faster control over formatting compared to other methods I've tried. The problem I described above has been occurring for a while but I've only just worked out exactly what has been happening. I've been copping a lot of criticism and just accepting it, saying to people that I must not be doing my job properly. But I now don't believe that it's my fault.

    Before the past few weeks, I have never noticed this behaviour. And I don't believe it is something that could be missed!

    So, in addition to all of the above, has anyone else encountered this, or similar?

    Blessings,

    Andrew

  • @AndrewK so, there's a little bit of background to this. OpenLP uses the Qt framework for all the windows and buttons and things, and that includes the "open file" dialog that you see when you import your images. Our code essentially just calls the "open file" dialog and then gets a list of files back from the dialog. The order of that list of file names is not controlled by our code. We could sort the list of files once we get them from the "open file" dialog, but that may cause problems for other people.

  • edited March 2022

    I am wanting to transition to 2.9.4 from 2.4.6. I use code developed by @fiveofsix to change scenes in OBS and it has worked brilliantly. My problem is within newly installed 2.9.4 I am unable to activate the remote stage view. On a tablet running OpenLP app I can see "Service List" and "Live List" but Stage and Live View will not connect. Clicking on Stage url in remote interface results in "requested URL was not found on the server". Is this a bug? Would backing up to 2.9.2 allow stage view to work or am I just missing something? Thanks so much for the work you do in developing OpenLP, I am a long time user.

    I've been working on this for days. Laptop running 2.4.6 works; I am able to see /stage and stage/obs so can control OBS but nothing I've tried allows me to see /stage on desktop running 2.9.4. I changed ip, ran ipconfig to confirm what Remote interface is displaying, closed Widows Security/firewalls briefly, rebooted modem and computer, reinstalled 2.9.4 and nothing helps. Both computers are hard wired to the modem. I realize that going to an earlier version is likely not a good idea but will have to stay with 2.4.6 until this is resolved. Thanks again.

  • @raoul, okay, I understand. I don't necessarily like, but I understand.

    But why does it 'sort', or keep them in the right order on some occasions but not on others?

    Having to check the order of every imported list of images of three Bible readings every week is going to significantly impact my workflow. There has to be a better way

  • @AndrewK , not sure if its the same problem but does it happen when you have more than 9 image files? I export powerpoint slides to .jpeg files for our slides and when I have more than 9 for a hymn, it always messes up and places them in slide10, slide1,slide2,3,4 order. I resolve this by starting my image numbering as image11, image12, etc. and it seems to resolve the issue.


  • @hoop, thanks for the suggestion.

    I don't know with any certainty if it happens with a particular number of slide files. Last Sunday's Old Testament Bible reading certainly had more than 9 slides, but it messed up the sorting way before it got to that number!

    The first screenshot is the way that the images are 'arranged' when I export them from Keynote.

    Maybe it's my workflow that is causing the problem because at this point I put the OT, NT, and the Gospel Bible readings into their own Groups inside Images in the Library. That seemed sensible to me to keep things tidy but maybe it's causing other problems. Anyway …

    When I import the png files to OLP, everything in the data library looks right. My screen isn't big enough to show the complete Group, but here's a snippet that shows most of it.

    And here is where things go awry. When I sent that Group to the Service, this was the result!


    Where did that come from? @raoul

    I honestly don't think that I'm doing anything strange or wrong, but I'm not so arrogant to say that I'm definitely not! I'm trying to make my life here as simple as possible, but if what I'm doing is causing the problem, then I have to change what I'm doing. But I need to know what I'm doing wrong, and I need to know that any change is going to be for the better.

  • We had a similar issue, but the remote update fixed it.

    We have a subsequent issue.

    We run OpenLP on a Intel PC with a Radeon GPU with two monitors attached. I run ProPresenter on the OpenLP PC.

    We also use a second PC running Vmix to add a web browser input from OpenLP Remote http://hostname/main:port

    We use OpenLP only for Bible Projection. We use a Zefania bible.

    It used to work without issues with the stable release but I really wanted the new UI. I thought it would fix the issue with the bible not displaying in biblical order.

    At first we had the black blank screen. We updated Vmix to Version 25 and it started behaving like we are used to.

    Two problems 1) desktop no longer shows desktop it shows my Propresenter instance. 2) that Vmix seems to have a cache problem with the web server It never seems to fetch the latest image. This was never a problem before.

    Thank you very much for all your efforts.

  • @AndrewK aaahhh, yes, I did force alphabetical ordering in the folders, but I think that might have only happened after 2.9.4. I remember fixing it though, so it should be part of the next release.

  • @wildo5053 you probably have not installed the web remote.

  • Now I'm confused. Do you mean the OpenLP app (for Android in my case)? I refer to that in my post as installed. In 2.9.4 the only reference to web remote that I see is "Current version 0.9.7" and no installation seems possible. If it helps, all servers in Server Status are active.

    Your response to me by email "Thanks for the bug report! We're tracking this in issue #1045 so I'm going to close this one." suggests that this is a problem within the program, that you are working on and not something I have done or not done. If you would clarify: is this remote feature in 2.9.4, accessing a web browser, working at all?

    Thanks for all you do and your response to my problem.

  • @wildo5053 Yes, the web remote does work. We have actually deprecated the Android remote since we don't have anyone actively developing it, and we'll be removing it and support for it in a future version of OpenLP.

    If you have the web remote installed, and you're getting that "requested URL was not found on the server" error, then I'm guessing you're running into an issue I've seen once before on the forums, but have never reproduced myself. For some reason, the remote is not downloaded and installed properly. OpenLP thinks the remote is installed, but it isn't.

    In our current development version, I added a way for OpenLP to check if the remote is truly installed, which will get around this problem that I cannot reproduce. This will be part of the next release.

    I don't know which exact email you're referring to, they all come into our issue tracker, and I've gone through a number of them recently. I'll also often close a bunch of emails/issues from users that all refer to the same problem, and just track it in a single issue (keeping 10 issues open that are identical just clogs up the system and causes more work than necessary).

    Also, I'd like to note that not all things I work on are problems within OpenLP. There are a number of issues that are external to OpenLP, but we add code to work around the external issue, or alert the user to the issue.

  • @wildo5053 I went back and searched through our issues and found the one you submitted. It is unrelated to the remote.

  • what should i do? It appeared when i first started the app

  • @Sbeff I remember seeing people mentioning this on Windows, I think it had to so with HDPI(? aka high density displays) settings, and "Scaling applications" setting. Maybe look in your settings and see if you can find something like that? I don't use Windows.

  • So I am guessing we went backward on the transitions since it worked in the prior 2.9.2 portable but not the newest?? Is it going to be fixed? Thanks for all you do! If I could program I would love to help but Im bearly code web.

Sign In or Register to comment.