ERROR: Unable to initialize the following plugins: Media

I am running an M1 Mac mini with MacOS Monterey v 12.1 and OpenLP v2.9.4. I was building a service and Open LP crashed. When I reopened, I was greeted with the error message "Unable to initialize the following plugins: Media."

I had a few MP3 files in Media. I had linked some of the MP3s to hymns so I would have the option to play music if we had no organist for that service. The service I had built for this coming Sunday included three hymns with MP3's attached via the Media tab in the Song Editor. I also had a Prelude MP3, a Postlude MP3, the Gloria Patri MP3, and the Doxology MP3.

I did try to downgrade to OpenLP v2.4.6, but it wouldn't open because there were still some reminants of v2.9.4 hanging around. I tried another fresh installation of v2.9.4, it works, but I still get the same error message about the media plugin.

Ironically, the service I created and saved will still load in OpenLP and will work. The MP3 files linked to the songs will still play, as will the stand-alone MP3 files I added to the service via the Media tab (when I had one).

I should note that it was not working perfectly before this happened. Sometimes the MP3 file attached to the hymn via the Media tab would not show or play.

I would really like to get the Media plugin/tab working again with either OpenLP v2.9.4 or v2.4.6. Can someone point me in the right direction to get this working again?

Note about my experience with OpenLP. I used it when we were attending a different church about 5 years ago. I am the media coordinator for the church we now attend. We are in the process of upgrading our live-streaming. We are adding two additional cameras, a video switcher, multi-camera controller, and more. Remembering my great experience with OpenLP, I am hoping to use with for lyrics and more for our live-streaming. I have created a theme with a transparent background that will be mixed with our live video with the switcher.

Thank you.

Jim Fisher

Port Huron, Michigan USA

P.S. I do have the .log file from running debug


Sign In or Register to comment.