1.0 rc4

edited November -1 in Development

Please post your bug reports about 1.0 RC4 here. Remember to read up on how to submit a bug report before posting your bug.


  • edited September 2007
    Only had a quick look. (I think someone up there is giving me a lesson on patience... eagerly await RC4 and then it gets released just as I am about to leave for a two week holiday!)

    I think many of my gripes have been addressed :-)
    I suggest anyone about to post new problems look in the settings first, since there are new options regarding word wrap and how Bible chapter numbers are shown etc.

    The only niggle I have now is when it comes to selecting many Bible verses. I think you have to highlight them all before you can display them (unless I am wrong), and pressing Ctrl-A to do this pops up a save order of service dialog!

    Would it be possible for all the verses to be automatically selected after pressing search, as this would speed up the time it takes to get them to screen.

    But other than that, looks great, well done :-)

    And Raoul, have a great wedding!

  • edited September 2007
    Used RC4 tonight in our service. It worked well with the songs staying the same size.

    But I noticed in the first song the last letter of the last word of the last verse was missing.
    On investigation I discovered the last character of the song is missing in Preview and Live. It is there in Edit.
    Most songs on the database have a "." or a blank line so would not show the error. In two cases I had neither so "now" became "no" and "breath" became "breat".

    Also I managed to trigger the "Out of Bounds" error. Delete song/bible verse from the Order of Service and then delete another quickly after. This seems to trigger the error. Wait 5 seconds and the error does not occurs.

    Added the NIV from the utilites provided and have an interesting problem with Luke 10:26. It does not wrap. It just continues to the left and does not display. Any ideas?
  • edited September 2007
    With reference to the "missing character" problem.  Can you tell me which display mode you were using 'Auto resize...' or 'Wrap long lines...'? I have not seen this problem, but then I always use the 'Auto resize...' option.
  • edited September 2007
  • edited September 2007
    @TRB143 - I found a temporary work around... Just put a 'space character' at the end of each line...

    I've also noticed that rc4 is ignoring certain punctuation characters.
    One of the lines of one of our songs looks like this:
    'Come on and celebrate, celebrate'
    but what get's displayed is
    Come on and celebrate celebrate

    Had another example with an '!' dissapearing but I can't think of it at the moment...
  • edited September 2007
    I've tested rc4 on two different machines and noticed that the Auto Open Last OOS at startup doesn't work.... (I think it worked the first time I tried the feature, might have been an old OOS that I used to test) but since then it hasn't worked on either machine...
  • edited September 2007
    Firstly, thanks for the new option with the fixed font size and wrap long lines. All the 'old folks' in our church are much happier with the consistent font size.

    I've experienced a little problem with bible readings though. In the KJV and ASV versions that come with openlp I haven't experienced the problem but I've imported an NIV and it's here that I have a problem. It doesn't always wrap the lines. Had a reading from John 16:16-23 in which I noticed it... Now I know that it could be my data file that causes the problem but I don't see why it doesn't just treat it as a string of X lenght and wrap it...
  • edited September 2007

    Hi. Can you email me the file for me to check out. It should be in "C:\Documents and Settings\All Users\Application Data\\Data\Bibles\".  My email address is derek [at]  I'll take a look and see what I can find.  Derek.

  • edited September 2007
    Program won't run.Reports:
    OpenLP.exe has encountered a problem and needs to close.

    Error signature:
    AppName: openlp.exe
    ModName: kernel32.dll

    This is on a Gateway Laptop
    XP Home Edition
    sevice pack 2
    Intel Pentium 4
    Mobile CPU 1.60GHz
    512MB ram

    Uninstalled and reinstalled several times,no change.
    Version 1.0 rc3 will run, but not close. Must use Task manager to do so.
  • edited September 2007
    Please disable error reporting in Windows, as per this article, and then run the program again. Window's error reporting is actually useless, and only makes things harder for us developers.
  • edited September 2007
    Have a look at Luke 10:26 as well
  • edited September 2007
    Thanks, we should be able to limp through service Sunday. As per your instructions, I followed the procedure to disable error reporting, I still get message on first start up, but program opens and seems to function until shutdown. Upon attempting to exit you get an "unspecified error." box with OK button. Clicking OK just returns you to the program. Must use Task Manager to exit. Program not responding message comes up, but you can shut the program down.

    Upon further investigation, I found that PowerPoint had a glitch. I ran detect and repair in PowerPoint and now the problem has disapeared.
  • edited September 2007
    Did some more work on RC4 last night for Sunday. The found RC5 was out.
    With RC 4 I have been using the Fixed width across all slides and found this usable.
    The problem I am now having is with the area of the screen we can use.

    Coming from a PowerPoint world we can adjust the margins for the song. Can this be added to the Templates so the right and left margins can be set. This can be defaulted to what ever is used currently but that will give greater control over formatting. On our setup and a number of songs wrap one word onto a separate side.

    As a second request to also help can the copywrite details be placed on 2 lines instead of 4. This would mean that the song title and author would be on one and the CCL No and copy write on another.

    This two "minor" fixes will increase the screen real estate.
  • edited September 2007
    Ummm, to implement these new features will take a huge amount of time.  And the next obvious issue is specifying the height of the text area.  The fixed font size option is extremely difficult to format from a software perspective because you have no fixed information with which to make the formatting 'nicer'. What might be able to be done at this stage is if the last word of a verse is the only thing on a slide, rather move the entire line to the next slide. We may consider that a 'bug' to be fixed now.  The specifying of text area is definitely a new feature and we are in feature freeze for V1.  It has been added to the wishlist for the next version however.  I know there are issues with it, but to increase screen size, you can hide the CCLI/Author/Song title information.  
  • edited September 2007
    I found the same problems with RC4.
    RC5 also has the problem with the disappearing commas, I am using a temporary solution of using character number 130, which is an alternate comma. To get that symbol, you can either use the character map, or press and hold the 'Alt' key and type in 130 on the NUMERIC keyboard. When you release he 'Alt' key, you should get the new symbol. Yes, I know it is isn't very pretty, but RC5 seems quite happy with that.
  • edited September 2007
    Hi Titus/Faros.  Can either of you email me the song text of a song which has disappearing comma's etc at derek [at]  I don't see the problem, but I would like to get it fixed for you. Thanks, Derek.
  • edited October 2007
    OK, I think I've got this fixed.  It only seemed to happen in the 'fixed font' slide format.  Try the 'Auto-Resize' slide format and see if the problem goes away just to confirm this for me. Thanks, Derek.
  • edited October 2007
    Hi Derek.
    Yes, it appears that the Fixed Font setting is giving the problem; t appears to be OK on the Auto-resize. Thanks for looking at the problem.
Sign In or Register to comment.