Windows 8.1, Powerpoint / LibreOffice and Projecting - a real problem

edited February 2014 in Troubleshooting
Now that I have connected a projector up, my previous post is in tatters.

I will give as much information as possible to help those who may be able to help me:

I have:

    •    A brand new HP Pavillion Laptop, Windows 8.1, not mucked about with
    •    OpenLP v 2.0.4
    •    Powerpoint viewer which I downloaded from here: from here: which took me here:
    •    LibreOffice

Following a posting on the forums, (Sorry cannot find it at present) I started the system up like this:

    1.    With everything off, plug the system together
    2.    Turn on the Projector, and wait for it to come on fully
    3.    Turn on Laptop
    4.    Select the Screen options in Windows - press Win key + P and select “Extend”
    5.    Start OLP and load up a service

The following problems were now evident:

    1.    LibreOffice sort of worked, but the presentation mode was there in the background, messing up the display.  Not usable.
    2.    The “Taskbar” although fairly translucent, was always there, and in the way.  Using Autohide helped sometimes and sometimes failed to help.  Projecting song words also had the taskbar visible
    3.    Attempts to project PowerPoint caused OLP to lock up and eventually crash.
    4.    Sadly all this means that OLP is not usable

All in all it was not a happy outcome.

I solved the LibreOffice problem of presenter mode running in the background by going here:

c:\Program Files(x86) LibreOffice 4\program  and looking for PresenterScreenlo.dll and renaming it to PresenterScreenlo.dll.OLD  This fixed it.  

However I am unable to sort the other issues, and, as it stands, OLP is not usable.  I am very disappointed as I have been happily using it for a few years now on Windows XP and Windows 7

Does anyone have any ideas to help me here?

Thank you in advance.


  • Hi Ed, don't panic, Win 8.1 takes a little getting used to.

    Regarding that taskbar ... right-click on the taskbar and turn OFF the option “Show taskbar on all displays”.  That should help a lot.

    It might be best not to use autohide because it helps to see that taskbar when you are learning to use Powerpoint and OpenLP together - you need to know which app has the computer's focus. 

    Take a break, then have another go 


  • presenter mode off does not require deleting of PresenterScreenlo.dll in libreoffice version 4.1 and higher.

    You will find if you go into impress directly and go to the impress options you can turn it off.  Result you can apply libreoffice updates and it stays off.   Your method when up update libreoffice it will be back to annoy you again.

    Try Powerpoint viewer  without OpenLP I think you will find exactly what I found when I did a windows 8.  Powerpoint viewer seams Windows 8 incompatible and even some what Windows 7 incompatible.   MS Office 2010 and MS Office 2013 are not much better with OpenLP.  Read the supported operating  systems and system requirements.   Last supported Windows 7 and direct x 9 c graphics card.

    Making direct x 9 applications work under Windows 8 can be trouble.   If your system is Nvidia make sure you have your video card drivers installed.    If your system is AMD or Intel its luck of draw if a direct x 9 application will work or will crash.  Worse crash and reboot complete system.

    Good or bad with just Libreoffice impress OpenLP will still show power-points just not as good.

    I am not sure if libreoffice is OpenLP compatible.   In fact I was coming to ask if anyone had tried this out under Windows.   I do know Libreoffice 4.1 will install on Windows 8 and work with OpenLP ok.
  • Hi Ed
    Try using powerpoint viewer 2007 instead: it works for me on win 8.1.
    You can easily remove the taskbar from your second screen. Just right-click the taskbar, choose properties and in the window that opens un-check "Showtaskbar on all displays".

    I hope this helps!
  • Well hats off to LibreOffice, and the opposite to PowerPoint viewers of all flavours!

    Fixed the Taskbar - thanks to SteveB_001 and tgc for that.

    Also fixed the LibreOffice Presenter mode in the more conventional manner - thanks oiaohm.  I looked for that setting, and missed it!

    Now OLP is happily showing a LibreOffice Presentation faultlessly!  As I use LibreOffice to create my presentations, I gain!

    oiaohm - you wondered if LibreOffice is compatible with OLP?  I am using LibreOffice with the latest OLP so it does!

    Thanks everyone for your help.  Much appreciated. I can now let my hair grow again!

    PS If anyone else has come to this post for help, may I recommend the switch on procedure that I documented above.  It really does work, and saves a lot of heartache.
Sign In or Register to comment.