Media problem with Mac, new VLC

I just installed a new version of VLC: 2.2.1 on my Mac running 10.10.3 and using OpenLP 2.1.3. Prior to the update, I was able to play mp3 files using VLC. Now the Preferences sections says that VLC is not available, nor is phonon or Webkit. Phonon and Webkit have not been available since moving to 2.1.3, although VLC did work for audio. However video files would play the video in Preview and the audio in Live,  but no audio in Preview and no video in Live. I tried reverting to VLC 2.1.5, but no luck. I did try restarting and running VLC but no results. Any ideas?

Comments

  • The problem might be that the new OpenLP betas need VLC 64 bit version. Maybe you got the 32 bit version...?
  • On further experimentation, this is what I have found. Version 2.1.5 and 2.2.1 of VLC are both 64 bit. By renaming version 2.1.5 to VLC and placing it in the Applications folder, OpenLP will recognize and use it. When it was named VLC(2.1.5), it would not recognize it. OpenLP will still not recognize version 2.2.1, no matter where it is or what it is named. So now I can play mp3 files (but not m4a or mp4 files), even though VLC as a standalone program will play these files. And for video, I still have the problem of no audio when previewing a file and no video when I try Live view with a file. And I can't try phonon or webkit, as they are unavailable. 
  • Thanks for doing this experimentation, it helps us fix the issue! I'll get one of the developers with a Mac to look into it.
  • Just wanted to let you known that OpenLP 2.1.4 has just been released which contains a fix to this issue. Please upgrade and try again.
  • Thanks for the update. An amazing amount of work in such a short time! The m4a and mp4 files are now readable. Version 2.2.1 of VLC is still not recognized by OpenLP. And the video problems I mentioned about persist. But these are minor issues and certainly no rush in getting them running. 
  • It seems I misunderstood one of my fellow developers: The fix for VLC 2.2.x on Mac did not make it into 2.1.4, but will be in the next release. Sorry about the confusion!
  • So to update my experience. I have updated to OLP 2.1.6 and am using VLC 2.2.1. It works fine for audio files, but for video files (mp4 or m4v) the video plays in the preview screen with no audio. And the audio plays in the Live screen, but no video. And I am unable to link an audio file to a song. The software says that it is linked, but nothing plays when projecting the song. These are not deal breakers, as I can play the video using VLC, but just wanted to let you know where things stand. Thanks for all your work! I am running OS X 10.10.5 on a Mac. 
    Chris
  • Hi Chris,

    I've been having similar problems to what you've been describing, but I hadn't even got as far as getting OLP to recognise VLC (for more than about 15 minutes).

    Having read your thread today, I have solved my video and audio problems. Thank you so much for your help!

    The only difference, that I know of, between your setup and mine is that I'm still running OS X 10.9.5.

    If you want to discuss anything, feel free to PM me, if that's allowed. See if we can work out your issue.

    Cheers,
    Andrew
  • Unfortunately playing linked audio does not work on Mac (and maybe Windows too) in 2.1.x and in the upcoming 2.2. This will be fixed in 2.4 which we hope to release a few months after 2.2.
    I don't have a Mac, so can't help out with the missing audio/video when playing video.
  • edited September 2015
    Hi All.  I am a newbie here.  To begin, the following are my quick specs:
    OS: Windows 7, 64bit
    OLP: 2.1.6
    VLC: 2.1.2 32bit
    External monitor attached to my laptop via VGA cable

    I installed OLP 2.1.6.
    In OLP under Settings, Configure OpenLP, Players, selected VLC
    Linked an audio .MP3 file to some random default list of songs that came with OLP:
     - right clicked the song
     - Edit
     - Linked Audio
     - Add files
     - selected some random .MP3 file
     - clicked open
     - clicked Save
     - double clicked that song and it went into Preview window
     - (personally I feel it makes sense not to have audio in preview mode as I do not want to have my audience hearing what I am previewing)
     - clicked the "Move to live" button.  Now, in the Live window, you will notice that the audio is in Pause mode.  You will need to click the Pause button to start the song.
    image


    image

    Worked great for me on Windows 7.
    But yes, I did notice you are using Mac.  This short test just confirms that it works on Windows.
    I am so looking forward to seeing the ability for background video to be incorporated instead of only Audio! :D  That would be so awesome!
Sign In or Register to comment.